WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 9 months ago

#44525 closed defect (bug) (duplicate)

Adding non-hierachical terms containing a comma, breaks tags-box autocompletion

Reported by: enrico.sorcinelli Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Taxonomy Keywords:
Focuses: ui, javascript, administration Cc:

Description

I searched over tickets archive but apparently I couldn't find a similar one.

To reproduce in UI:

  • Create/edit a term in a non-hierarchical taxonomy (by edit-tags.php/term.php), inserting a comma inside the name.
  • In the tags boxes of post edit screen, search and select inserted term.
  • By adding the term and update the post, two (or more) terms will be created if they don't exist and then will be associated to the post.

This also happens similarly on quick/bulk edit after applying changes.

Gutenberg don't seems to be affected.

After a quick look, the patch is not as simple as it may seem. The comma is used as term separator in input value attribute, so It's not directly possible to escape it.

Change History (1)

#1 @boonebgorges
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @enrico.sorcinelli - Looks like this issue has been raised before. See #14691, and the patch there.

Note: See TracTickets for help on using tickets.