WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#44535 closed defect (bug) (invalid)

Reporting a Bug

Reported by: fedemodern Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Date/Time Keywords:
Focuses: Cc:
PR Number:

Description

Quando viene usata la funzione the_date(), in tutti gli articoli scritti nello stesso giorno la data non viene visualizzata.

Change History (2)

#1 @swissspidy
16 months ago

  • Component changed from General to Date/Time
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey there and welcome to WordPress Trac!

To translate your report: You say that when using the_date() in a loop, the date is only shown once when two posts have the same date.

This is not a bug. This is by design.

In other words, the_date() only works for the newest post in any single day in the loop. get_the_date() always gives you a date.

#2 @tw2113
16 months ago

To add to this, please see the "Special note" at the top of https://codex.wordpress.org/Function_Reference/the_date as it talks about the same thing.

Note: See TracTickets for help on using tickets.