WordPress.org

Make WordPress Core

#44657 closed defect (bug) (duplicate)

Audio shortcode is not working with Dropbox links

Reported by: gemmaevans Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Shortcodes Keywords:
Focuses: Cc:
PR Number:

Description

The problem

Audio files in Dropbox no longer play when embedded using the audio shortcode, even though the file is publicly available.

Steps to reproduce

  1. Upload an .mp3 file to Dropbox.
  2. Copy the Dropbox link (public).
  3. Create a new post.
  4. Add the Dropbox file URL to the audio shortcode in the post using [audio src="FILE-URL.mp3"].
  5. Publish the post.
  6. View the post on the front end and click play on the audio player.

The result

I expected to be able to play the .mp3 file from within the post — but this does not happen and the player displays a time of 0:00. The Dropbox URL plays back if I visit it directly in a browser but not once it has been embedded into the post.

Discussion on the [Dropbox forum https://www.dropboxforum.com/t5/Photos-and-videos/mp3-URL-ending-with-mp3/m-p/194990/highlight/true#M12261] suggests the audio file should be playable if ?raw=1 is added to the end of the URL. However, the shortcode doesn't seem to recognise this an audio file because it doesn't end in an audio extension like .mp3.

Originally reported in: ​https://en.forums.wordpress.com/topic/audio-shortcode-not-working-on-free-plan/

Change History (1)

#1 @ocean90
16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from enhancement to defect (bug)
  • Version 4.9.7 deleted

Hello @gemmaevans, thanks for the report. The underlying issue is wp_check_filetype() not recognizing the file extension. We're already tracking this issue in #30377.

Note: See TracTickets for help on using tickets.