WordPress.org

Make WordPress Core

Opened 14 months ago

Last modified 14 months ago

#44869 new defect (bug)

The New Text Widget doesn't Work in the Visual Customize on First Use

Reported by: pbee11 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.8
Component: Customize Keywords: reporter-feedback
Focuses: administration Cc:
PR Number:

Description

I'd like to report a bug with the new Text Widget on WordPress 4.9.8. I'm on a fresh install, no plugins enabled, default theme. When I go to the Customizer > Widgets > Sidebar and try to add a Text widget, everything seems fine, I'm adding the title, content and then—it hangs—for basically forever. It loads and loads—when I click publish and refresh the customizer all I can see is the Text widget without a title and without any content. I can then edit the widget and save.

This only happens when you add the widget and you proceed to edit it immediately, in the same session. Once you save and refresh, everything seems to work fine. Also, there are no errors in the console.

Let me know if y'all have any more questions. I'm committed to solving this. Hope that this makes sense and is helpful ;)

Change History (3)

#1 @mukesh27
14 months ago

  • Component changed from General to Customize
  • Focuses administration added
  • Keywords needs-screenshots added
  • Summary changed from The New Text Widget doesn't Work in the Visual Customizer on First Use to The New Text Widget doesn't Work in the Visual Customize on First Use

Hi @pbee11, welcome to WordPress Trac! Thanks for the ticket.

#2 @dlh
14 months ago

  • Keywords reporter-feedback added; needs-patch needs-screenshots removed
  • Severity changed from major to normal
  • Version changed from 4.9.8 to 4.8

I'm unable to replicate this behavior on a clean installation. @pbee11 can you please verify that your theme is Twenty Seventeen and whether there are any related messages in the PHP error logs?

The support forums might be a better place to bring this issue first to rule out any potential causes of the behavior that are specific to your site or server, as suggested by the long server-response time. Discussion on the forums can also help determine steps to consistently replicate the behavior to bring back to this ticket.

#3 @westonruter
14 months ago

Please Also look at the browser's JavaScript console to see any errors that may be reported there.

Note: See TracTickets for help on using tickets.