WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#45324 closed defect (bug) (invalid)

Twitter auto embedding breaks if user name starts and ends with an underscore

Reported by: edent Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Editor Keywords:
Focuses: Cc:

Description

  1. Try to embed a Tweet where the user's name starts and ends with _
  2. For example https://twitter.com/_sagesharp_/status/1061094348152918017
  3. The text is rendered as https://twitter.com/<em>sagesharp</em>/status/1061094348152918017 rather than an oembed.
  4. The JetPack MarkDown processor is incorrectly interpreting the underscores in a URL as being valid MarkDown.

Tried on a fresh install of 4.9.8, with only JetPack installed, MarkDown editing switched on, and using the classic editor.

This works fine for embedding [tweet 1061094348152918017]

Attachments (2)

Screenshot at 2018-11-10 12-27-56.png (27.3 KB) - added by edent 6 months ago.
Incorrectly rendered tweet
Screenshot at 2018-11-10 12-27-12.png (12.2 KB) - added by edent 6 months ago.
MarkDown editing

Download all attachments as: .zip

Change History (4)

@edent
6 months ago

Incorrectly rendered tweet

@edent
6 months ago

MarkDown editing

#1 @swissspidy
6 months ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there and welcome to WordPress Trac!

You mentioned that you use Jetpack and that its Markdown processing incorrectly handles the Twitter URL.

Jetpack is a WordPress plugin developed by Automattic and is not part of WordPress core or anything. That means you have to report this issue directly to them as it's not caused by WordPress.

Note: See TracTickets for help on using tickets.