WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 19 months ago

#45388 closed defect (bug) (invalid)

Hyperlink Errors

Reported by: nhfrega Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Canonical Keywords: reporter-feedback
Focuses: Cc:

Description

Sometimes, hyperlinks decay and link to another page on the site than the one initially linked.

Change History (2)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Canonical
  • Keywords close reporter-feedback added

Hi @nhfrega, welcome to WordPress Trac! Thanks for the report.

If I'm reading this correctly, the issue is that once a post is deleted, any links to it would now link to another post with a similar slug.

That's not a bug, it's WordPress trying to guess the correct URL using the redirect_guess_404_permalink() function.

If you'd like to change this behavior, there's a plugin for that: Disable URL Autocorrect Guessing.

#2 @desrosj
19 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I'm going to close this one out. It appears this is working as expected and there has been no additional reporter feedback.

Note: See TracTickets for help on using tickets.