WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#45436 closed defect (bug) (duplicate)

V4.9.8 RSS Widget use old SimplePie and give errors

Reported by: AndreasL Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Widgets Keywords:
Focuses: Cc:

Description

I use the stock RSS widget to pull this feed:
http://status.df.eu/rdf.xml

The widget give the following error:
Warning: A non-numeric value encountered in ...xxx...\wp-includes\SimplePie\Parse\Date.php on line 694

I take a look into and found an old version of SimplePie. I download the latest SimplePie version 1.5 from http://simplepie.org/ and replace Date.php to bring the widget back to work.

I verify it with RC5 and stock themes.

Change History (1)

#1 @pento
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the report, @AndreasL! We're tracking upgrading SimplePie over on #36669.

Note: See TracTickets for help on using tickets.