Make WordPress Core

Opened 5 years ago

Closed 5 months ago

#45774 closed defect (bug) (worksforme)

Twenty Nineteen: When no menu is set, PHP error displays and customizer won't load correctly

Reported by: programmin's profile programmin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: ui, administration Cc:

Description

When no menu is primary (In appearance-menus, "Primary" was not checked), the site customizer feature brings up a blank bar to the left, no customizer.

PHP Catchable fatal error: Object of class WP_Error could not be converted to string in /var/www/html/wordpress/wp-includes/general-template.php on line 4277

Change History (5)

#1 @laurelfulford
5 years ago

  • Summary changed from Twenty Nineteen: to Twenty Nineteen: When no menu is set, PHP error displays and customizer won't load correctly

#2 @eddr
5 years ago

can't reproduce with the theme. Has one menu and "Primary" menu location, customizer works well
Please add more information - WP version, plugins in use.

Does it happen with plugins turned off?

#3 @laurelfulford
5 years ago

  • Keywords reporter-feedback added

Thanks for reporting this issue, @programmin, and for your testing, @eddr!

I'm also unable to recreate this issue. It's possible it was fixed in Twenty Nineteen when another issue was fixed. Or as @eddr suggested, we might need more information about your setup to reproduce.

@programmin can you please confirm if this error is still happening for you, and if so, please let us know what version of WordPress you're using, what version of Twenty Nineteen, and any plugins you may have installed?

Thank you!

#4 @poena
14 months ago

  • Keywords close added

I activated version 1 and then version 1.4 of the theme without menus, and I could not reproduce it. I tested on WP 5.7 and 6.2.
I suggest closing this issue as fixed.

#5 @hellofromTonya
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

As there are multiple reports of not being able to reproduce the issue and there's been no further follow-up, I'll close this ticket as worksforme.

However, @programmin if the problem still persists today, please reopen the ticket and provide more information such as step-by-step instructions on how to reproduce (helps contributors).

Note: See TracTickets for help on using tickets.