WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 3 months ago

#45808 closed defect (bug) (invalid)

New block editor conflicts with Organic Builder Widgets customizer

Reported by: bluesplash26 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.2
Component: Editor Keywords:
Focuses: ui Cc:
PR Number:

Description

We recently upgraded to WordPress 5.0.2 with the new block editor. It has introduced an intermittent problem where Pages that use the Organic Custom template occasionally load with the block editor interface, instead of with the Organic Custom Widgets Page that allows the user to directly access the WYSIWYG widget customizer. We have a WordPress multi-site install that displays information in pages that use the Organic Custom template provided by the Organic Builder Widgets plugin
https://wordpress.org/plugins/organic-customizer-widgets/

Sometimes it is possible to fix the problem by looping through the View Page -> Edit Page options on the top WordPress toolbar, then the customizer may appear on reload of the editor, but this is not always a reliable workaround.

I appreciate that this problem may be in the plugin and not WordPress core, however it feels that it could be a core issue as it seems to be intermittent and the loading of the customizer view for the page editor may be something handled by WordPress itself?

Attachments (2)

GainesvilleBlockEditor_ErrorState.png (30.6 KB) - added by bluesplash26 10 months ago.
When the block editor overwrites the Organic Custom template for the page
GainesvilleCustomizerEditor_CorrectState.png (49.6 KB) - added by bluesplash26 10 months ago.
When the Organic Custom template is correctly applied and the editor displays the customizer

Download all attachments as: .zip

Change History (4)

@bluesplash26
10 months ago

When the block editor overwrites the Organic Custom template for the page

@bluesplash26
10 months ago

When the Organic Custom template is correctly applied and the editor displays the customizer

#1 @bluesplash26
10 months ago

We've installed the Classic Editor plugin to revert to the old functionality across the site in order to reliably resolve this problem. Please let me know if the Block Editor is updated to include a patch for this issue, as it would be great to have the option of using that too. Thanks.

#2 @garrett-eclipse
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @bluesplash26 thank you for the report.

Reviewing it appears to have been a compatibility issue with the new block editor (Gutenberg) introduced in WP 5.0 and the Organic Builder Widgets plugin. As you found the Classic Editor plugin is a great stopgap while plugins work on supporting the new editor.

On the plugin Changelog there are some mentions of Gutenberg updates and they're showing 'Tested up to 5.2.2' the most recent version of WordPress with the last plugin update a week ago. If you test with the latest version of WordPress and the Organic Builder Widgets plugin I'm hoping you'll find the issue is resolved.

If the problem persists after the most recent updates it's best to reach out to the plugin developers either through their Free WP.org Support Forum or their other support channels as it seems they have their own forums and support via their website.

As this is a plugin compatibility plugin I'm going to close this issue.

Note: See TracTickets for help on using tickets.