WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#46147 closed defect (bug) (fixed)

Fix TinyMCE wpviews when running from /build

Reported by: azaozz Owned by: azaozz
Milestone: 5.1 Priority: normal
Severity: normal Version: 5.0
Component: TinyMCE Keywords: commit
Focuses: Cc:

Description

There is a regression when running from /build and loading TinyMCE without SCRIPT_DEBUG set to true. The wpview plugin doesn't initialize properly in the Classic Block.

Attachments (1)

46147.diff (1.5 KB) - added by azaozz 3 years ago.

Download all attachments as: .zip

Change History (5)

#1 @azaozz
3 years ago

Happens because all TinyMCE plugins are concatenated together with tinymce.min.js, and the resulting wp-tinymce.js is loaded too early, before other scripts on edit-form-blocks.php. So window.wp doesn't exist yet when the plugins scripts run.

Patch coming up.

@azaozz
3 years ago

#2 @azaozz
3 years ago

In 46147.diff: set references to "optional dependencies" for TinyMCE plugins in PluginManager.add() which runs after TinyMCE initializes as the concatenated wp-tinymce.js may be loaded too early.

Last edited 3 years ago by azaozz (previous) (diff)

#3 @iseulde
3 years ago

  • Keywords commit added

Works for me!

#4 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 44718:

TinyMCE: fix external references in wpview and wpemoji plugins in the Classic Block instance when running from /build.

Fixes #46147.

Note: See TracTickets for help on using tickets.