WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 8 weeks ago

#46475 closed defect (bug) (duplicate)

Pagination bug on categories

Reported by: Marco Raaphorst Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Permalinks Keywords:
Focuses: Cc:

Description

When using /%category%/ in custom URL slug under Permalinks this creates links for posts using the categoryname in the URL. This creates a link like for example:
https://domain.com/categoryname/blog-slug

This also means that https://domain.com/categoryname/ will show a page of all posts under that categoryname. But on this page, pagination is broken. Page 2, 3 or so on will cause a 404 error.

See also https://wordpress.org/support/topic/blank-page-2-5/

Change History (5)

#1 @swissspidy
4 months ago

  • Summary changed from Pagenation bug on categories to Pagination bug on categories

#2 @desrosj
4 months ago

  • Keywords reporter-feedback added

Hi @marco-raaphorst, thanks for making this ticket.

Can you provide more details? I am having trouble reproducing the issue that you are describing.

I did some searching and I think this report could be a duplicate of #37812. Can you review that ticket and confirm that is the same issue?

#3 follow-up: @Marco Raaphorst
4 months ago

It's not the same as #37812. Although it is related.
Do this:

  • set a custom permalink structure like this: /%category%/%postname%/
  • now go to www.yourdomain/%category%/ and scroll down the page
  • click on page 2, 3 or anything you'd like and you'll get a 404

Btw this bug is very very old, I think since version 1.0 :)

Last edited 4 months ago by Marco Raaphorst (previous) (diff)

#4 in reply to: ↑ 3 @ehsanv
8 weeks ago

Replying to Marco Raaphorst:

It's not the same as #37812. Although it is related.
Do this:

  • set a custom permalink structure like this: /%category%/%postname%/
  • now go to www.yourdomain/%category%/ and scroll down the page
  • click on page 2, 3 or anything you'd like and you'll get a 404

Btw this bug is very very old, I think since version 1.0 :)

I also get 404 error when open subcategories links. This is odd, because when I click the subcategory link inside my weblog it works and shows subcategory items, But when I use the link from another website/bookmark/sitemap or Copy&Paste subcategory link in a new browser tab i face the same 404 error page!
I don't know if this is the same bug or not.

#5 @SergeyBiryukov
8 weeks ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #8905.

Note: See TracTickets for help on using tickets.