WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 2 months ago

#46534 closed defect (bug) (invalid)

WordPress Multisite subsite deletion cleanup bug?

Reported by: andreas.tyrosvoutis Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description (last modified by SergeyBiryukov)

Not sure if this is a bug or support problem.

Have a small multisite that a specifically named subsite (gymnostirio.XXXXX.com), no matter how many times destroyed/deleted and recreated with the same name, never shows images. Even if subsite is created on a different id.

This same subsite, restored to a different subsite name ( testexample.XXXXX.com) correctly displays images.

There seems to be a cleanup bug in multisite deletion code but I have no idea how to approach this.
Zero errors in Apache log or wp error log.

Change History (3)

#1 @andreas.tyrosvoutis
5 months ago

Small correction,

Have a small multisite that a specifically named subsite (gymnostirio.XXXXX.com), no matter how many times destroyed/deleted and recreated with the same name, never shows images. Even if subsite is created on a different id.

This behavior follows the subsite name through any id

#2 @SergeyBiryukov
5 months ago

  • Description modified (diff)

#3 @jeremyfelt
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.1 deleted

Hi @andreastyrosvoutis, thanks for opening a ticket.

I would recommend trying the support forums first to determine if this is an issue specific to your site or settings in some way: https://wordpress.org/support/. It's possible that through discussions there, a core bug is highlighted, but that workflow will likely work out better for determining what the issue is.

Feel free to reopen with more details if it turns out to be an issue in WordPress core.

Note: See TracTickets for help on using tickets.