WordPress.org

Make WordPress Core

#46564 closed enhancement (duplicate)

Option to disable plugins.php auto-disabling plugins

Reported by: ckeeney Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

Visiting /wp-admin/plugins.php calls validate_active_plugins which automatically deactivates any active plugins that have an error. I suggest supporting a way to disable this behavior. It is possible there are multiple instances of WordPress running connected to a single database that may not be configured identically.

In my specific use case, I have a production instance of WordPress running that relies on https://wordpress.org/plugins/wp-stateless/ to store media on Google Cloud Storage.

I plan to migrate to Google App Engine and when I do so I won't need WP-Stateless anymore (because I can mount GCS buckets into an app engine instance).

The simple solution is to get a new instance of WP running connected to the production database without WP-Stateless and then point DNS at the new instance. This works, but if an admin user on the new instance merely visits the WP Plugins page, the new instance will disable wp-stateless in the database and break the production instance before the DNS has migrated over.

I know this example is very specific and maybe even contrived, but I think users expect that they can safely browse the plugins page without breaking anything and today that isn't necessarily the case.

Change History (1)

#1 @johnbillion
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, @ckeeney , and welcome to WordPress Trac!

This is a duplicate of #27994, although that ticket hasn't seen much support.

Note: See TracTickets for help on using tickets.