WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#47801 closed enhancement (duplicate)

Apply Filters Change

Reported by: Dono12 Owned by:
Milestone: Priority: normal
Severity: major Version: 5.2.2
Component: Privacy Keywords:
Focuses: Cc:
PR Number:

Description

File Path: wp-includes/user.php

Data request emails apply_filters. share the same filter name for content as request to erase your personal data :

A user data privacy request has been confirmed:

<?php
$content = apply_filters( 'user_confirmed_action_email_content', $email_text, $email_data );

Your request to erase your personal data:

<?php
$content = apply_filters( 'user_confirmed_action_email_content', $email_text, $email_data );

Can You guys please change the Your request to erase personal data to something unique for email customization.
Maybe: user_erasure_fulfillment_email_content

Reason being when customizing these two emails there is a conflict caused by the filters.

Change History (1)

#1 @garrett-eclipse
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report @Dono12 we're tracking this over in #44314, there's a working patch there that just needs some testing, etc. Feel free to follow along and lend a hand there. Closing this as a duplicate.

Note: See TracTickets for help on using tickets.