WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 9 months ago

Last modified 9 months ago

#48070 closed defect (bug) (fixed)

Cmd+Shift+Enter comment submissions trigger 'Duplication comment detected'

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: has-screenshots close
Focuses: accessibility Cc:

Description

Hello,

Ran into this recently where submitting a comment using Cmd+Shift+Enter on Mac Chrome will trigger the 'Duplicate comment detected; it looks as though you’ve already said that!' message, going back I see the comment is actually created. This happens when logged in or out. And using the identical content but clicking submit instead of using the keyboard doesn't cause the issue.

Cheers

Attachments (2)

8129b14e4818145e3774df30fbbc7307.gif (154.8 KB) - added by garrett-eclipse 11 months ago.
Logged out submission
ad2f5b6feb73fba96d8b26f6a6815693.gif (243.6 KB) - added by garrett-eclipse 11 months ago.
Logged in submission

Download all attachments as: .zip

Change History (11)

#1 @garrett-eclipse
11 months ago

Please excuse those first two screens I grabbed the wrong ones on upload, uploading the right ones and the above can be removed.

@garrett-eclipse
11 months ago

Logged out submission

@garrett-eclipse
11 months ago

Logged in submission

#2 @garrett-eclipse
11 months ago

  • Keywords has-screenshots added

#3 @afercia
11 months ago

Please excuse those first two screens I grabbed the wrong ones on upload, uploading the right ones and the above can be removed.

I went ahead and removed them.

#4 @garrett-eclipse
11 months ago

Thanks @afercia, I appreciate that.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


9 months ago

#6 @afercia
9 months ago

Seems to me the actual behavior is different depending on whether you’re logged in.

Non logged in: pressing only Enter submits the content.

Logged in: pressing Enter doesn't do anything. Pressing Cmd + Enter (macOS Chrome) triggers the error message.

@garrett-eclipse can you reproduce this (when you have a chance)? Also, not sure why you're pressing also Shift. Maybe I'm missing something :)

#7 @garrett-eclipse
9 months ago

  • Keywords close added

Hi @afercia I can no longer seem to reproduce this using 5.3 so I am flagging for close.

I can only now seem to cause the message when it's actually duplicate content which is then the expected result.

If you can't reproduce any longer as well then let's close this out.

I believe I was trying Shift+Cmd+Enter because Cmd+Enter didn't seem to work. Both don't cause any issues now. As to your note on non-logged-in behaviour I believe you were in the name/email when you hit enter as they're required after the content. If you fill them and go back into the content Cmd+Enter is required to submit as it's a Textarea.

I appreciate you looking at this.

#8 @afercia
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

Thanks @garrett-eclipse. I can't reproduce either. Looks like the last changes in [45790] and [46700] fixed the issue.

To clarify: it was happening on trunk, correct?

#9 @garrett-eclipse
9 months ago

Thanks @afercia, I appreciate you finding the changesets. It definitely looks like those addressed the issue.

To confirm; yes it was happening for me on trunk but is no longer an issue on trunk or in 5.3.

Note: See TracTickets for help on using tickets.