WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#48148 closed defect (bug) (duplicate)

Wrong redirect link after logout (wordpress version 5.2.3)

Reported by: cmagrin Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.2.3
Component: Login and Registration Keywords:
Focuses: administration Cc:
PR Number:

Description (last modified by SergeyBiryukov)

Bug logout redirect (wordpress version 5.2.3)
Cause: There is no "/" before "wp-login.php?..." and the user is redirected to "http://wp-login.php/?loggedout=true"
(row 546 wp-login.php)

		if ( ! empty( $_REQUEST['redirect_to'] ) ) {
			$redirect_to = $requested_redirect_to = $_REQUEST['redirect_to'];
		} else {
			$redirect_to           = 'wp-login.php?loggedout=true';
			$requested_redirect_to = '';
		}

Change History (3)

#1 @dkarfa
4 months ago

Hi @cmagrin, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #47980.

#2 @cmagrin
4 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #47980.

Ok perfect, Thanks! I close the ticket

#3 @SergeyBiryukov
4 months ago

  • Description modified (diff)
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.