WordPress.org

Make WordPress Core

Opened 8 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#48359 closed feature request (duplicate)

Add WP_List_Table in Managing Menu Locations

Reported by: razib_ Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Menus Keywords: 2nd-opinion
Focuses: ui, administration Cc:
PR Number:

Description

Hi,

Problems:
Now we can not delete multiple 'nav_menu' terms. Once we import demo data, it is difficult to clean extra Menu item.

My opinion:
If we have WP_List_Table in "Manage Locations", we can edit/delete/delete-all 'nav_menu' terms easily.

Now we have Select dropdown options to manage menu locations, if we are used radio field to choose locations, it will be better I think.

I've shared a screenshot:https://drive.google.com/file/d/1NFMIhO1K6DVoapB80R7QvTY5YzAEt836/view?usp=sharing, please check.

Thanks for reading.


Change History (3)

#1 @SergeyBiryukov
8 weeks ago

  • Focuses accessibility performance ui-copy removed

#2 @welcher
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21603

#3 @welcher
3 weeks ago

@razib_ thank you for your ticket and welcome to trac! We have a ticket in place for managing multiple menu item removal.

Note: See TracTickets for help on using tickets.