WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#48380 closed defect (bug) (duplicate)

About: prepare about.php for inclusion of Jazzer's name

Reported by: tobifjellner Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Help/About Keywords:
Focuses: Cc:

Description

At string freeze, about.php contains two strings that, unfortunately, WILL change when WordPress 5.3 is launched. Furthermore, these strings also deviate from another piece of WordPress string standards.

_e( '“Name” adds even more robust tools for creating amazing designs.' );

And

printf(
/* translators: %s: The current WordPress version number. */
__( 'Introducing our most refined user experience with the improved Block Editor in WordPress %s “Name”!' ),
$display_version
);
  1. These strings contains the placeholder value "Name", which most certainly is going to be replaced with the name of a Jazzer at time of launch. In order to not create additional translation dependencies at time of launch, these strings Could use printf() to include the Jazzer's name dynamically. (Obviously this calls for inclusion of corresponding "translators" comments.)
  1. The Jazzer's name, when made public, also needs to be translated (or rather transliterated) for some languages. But most language teams will simply copy the English name without any changes.
  1. Usually WordPress code double quotes as “ and ”

It's probably best to follow the same format in these strings.

Change History (2)

This ticket was mentioned in Slack in #polyglots by tobifjellner. View the logs.


4 months ago

#2 @ocean90
4 months ago

  • Component changed from Administration to Help/About
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Closing as a duplicate of #47708 since the page is still work-in-progress.

The Jazzer's name should probably just be removed from the page since it's usually only revealed in the release post.

Note: See TracTickets for help on using tickets.