Opened 7 years ago
Closed 3 months ago
#48513 closed defect (bug) (invalid)
Maximum execution time of 600 seconds exceeded in /var/www/html/releases/20191106150212/wp-includes/class-wp-image-editor-imagick.php on line 155
| Reported by: | mattiasf | Owned by: | |
|---|---|---|---|
| Priority: | normal | Milestone: | Awaiting Review |
| Component: | Media | Version: | |
| Severity: | normal | Keywords: | close |
| Cc: | Focuses: |
Description
When running wp media regenerate --only-missing --image_size=lazy it fails after 6490 entries.
It fails with the following error:
6490/15784 No "lazy" thumbnail regeneration needed for "model13-32" (ID 35894). PHP Fatal error: Maximum execution time of 600 seconds exceeded in /var/www/html/releases/20191106150212/wp-includes/class-wp-image-editor-imagick.php on line 155 Fatal error: Maximum execution time of 600 seconds exceeded in /var/www/html/releases/20191106150212/wp-includes/class-wp-image-editor-imagick.php on line 155
If I go to the specific image (that I THINK is failing, model13-32) and then click "rebuild thumbnail" inside WordPress it works just fine.
Hmmm..
Change History (3)
Note:
See TracTickets
for help on using tickets.
![(please configure the [header_logo] section in trac.ini)](/chrome/site/your_project_logo.png)
Does this have anything to do with WordPress though? Seems like an issue with hosting/server environment - need to change the maximum execution time. At the very least, this should probably be instead reported at https://github.com/wp-cli/media-command/. Though, they've already dismissed similar issues: https://github.com/wp-cli/media-command/issues/207