Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#48584 closed defect (bug) (invalid)

Polylang 2.6.6 error with WP update

Reported by: macpacman's profile macpacman Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Plugins Keywords:
Focuses: Cc:

Description

Hi there,

Since I update my website to WP 5.3, a big error message appears on my header.

Warning: Declaration of PLL_Walker_Dropdown::walk($elements, $args = Array) should be compatible with Walker::walk($elements, $max_depth, ...$args) in /home1/macpacman/public_html/wp-content/plugins/polylang/include/walker-dropdown.php on line 94

It disappear when I deactivate Polylang but then I loose the multi language menu.

Polylang asked me to create a ticket here.

Change History (4)

This ticket was mentioned in Slack in #forums by yui. View the logs.


4 years ago

#2 @pbiron
4 years ago

That error message is a result of changes in WP 5.3 and the Polylang plugin will need to be updated to be compatible.

You can tell their support team to look at WP 5.3: Introducing the spread operator

#3 @Clorith
4 years ago

  • Component changed from General to Plugins
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version set to 5.3

Thank you for your report about this issue.

Trac is meant for bugs an enhancements in the core WordPress software though, and not in plugins made for it. That said, the Polylang team have put out a response to the warnings you are seeing at https://wordpress.org/support/topic/php-warning-214/

#4 @mensmaximus
4 years ago

The bug is known and gets fixed in version 2.7 of polylang

Last edited 4 years ago by mensmaximus (previous) (diff)
Note: See TracTickets for help on using tickets.