WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#48690 closed defect (bug) (duplicate)

WordPress 5.3 get_the_time() weird output

Reported by: timon33 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Date/Time Keywords:
Focuses: ui, template Cc:

Description

Hello.

I've just upgraded to WP 5.3 from the last 5.2 version.

The locale is set to Greek and all my tests are in that language.

The output of

<?php
echo get_the_time( 'l, d F Y H:i', $post->ID );
?>

is

Σάββατο, 19 20 Ιανουαρίου19 10:50
Saturday, 19 20 January19 10:50 in english.

where obviously should be:

Σάββατο, 19 Ιανουαρίου 2019 10:50
Saturday, 19 January 2019 10:50 in english.

It seems that it gets the first two digits of the year part and places it before the month.

I think this has something to do with the new dates in 5.3 and locale which by the way now recognises genitive cases correctly.

Best regards

Change History (4)

#1 @nielslange
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #48606.

#2 @nielslange
12 months ago

@timon33 Thanks for reporting this issue. Please note that this issue had already been reported and patched in #48606. The fix should be released with 5.3.1.

#3 @timon33
12 months ago

Search for

date()

and

get_the_time

before posting and no results came out. Sorry for the duplicate.

Thanks for the info.

Best regards

#4 @nielslange
12 months ago

No worries, @timon33! 😀

Note: See TracTickets for help on using tickets.