WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 6 weeks ago

#48732 closed defect (bug) (duplicate)

Twenty Seventeen is throwing a JS error on page display when a sidebar hasn't been setup.

Reported by: krmoorhouse Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.3
Component: Bundled Theme Keywords:
Focuses: javascript Cc:

Description

Error as it appears in the console:

Uncaught TypeError: Cannot read property 'top' of undefined
at belowEntryMetaClass (global.js?ver=1.0:124)
at global.js?ver=1.0:240

I was able to trace the issue to sidebarPos being "undefined" on this line.

sidebarPosBottom = sidebarPos.top + ( $sidebar.height() + 28 );

Change History (3)

#1 @audrasjb
2 years ago

  • Component changed from Themes to Bundled Theme

#2 @sabernhardt
4 months ago

  • Keywords needs-testing added

Sorry your ticket did not receive more attention earlier.

This looks like the issue on #53512, which was just fixed for WordPress 5.8. Please verify whether it works now.

#3 @sabernhardt
6 weeks ago

  • Focuses coding-standards removed
  • Keywords needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I was hoping for confirmation that the issue is fixed now, but I'll close the ticket as a duplicate of #53512.

If I'm wrong (about this) and the problem still occurs, please reopen the ticket.

Note: See TracTickets for help on using tickets.