WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 5 months ago

#48914 closed defect (bug) (invalid)

Wrong direction of closing quotation marks

Reported by: alexandernst Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Formatting Keywords:
Focuses: ui Cc:

Description

When a quotation mark is followed by a dot, a comma or a closing parenthesis, the direction of the quotation mark is inverted.

This happens with a default WordPress 5.3 installation.

No image "screenshot.png" attached to Ticket #1

Attachments (2)

screenshot.png (144.2 KB) - added by alexandernst 6 months ago.
Hello world – Test website.png (8.1 KB) - added by marcelo2605 6 months ago.

Download all attachments as: .zip

Change History (11)

#1 @jeremyfelt
6 months ago

  • Component changed from Themes to Formatting
  • Keywords reporter-feedback added

Hi @alexandernst, thanks for opening a ticket.

I'm not able to reproduce this yet:

wp> wptexturize( 'Mantener una versíon dl proyecto siempre en buen estado (la rama "master").' );
string(88) "Mantener una versíon dl proyecto siempre en buen estado (la rama “master”)."

Can you provide an example of the raw data used for the text rather than a screenshot? That will be helpful in trying to reproduce the issue.

Note this may also be related or a duplicate of #48602.

#2 @tobifjellner
6 months ago

@alexandernst This behavior also depends on which language version you're using. This looks like es_ES. Am I right?

#3 @alexandernst
6 months ago

@jeremyfelt Here you go:

<p>A continuación, para desarrollar nuevas funcionalidades del código, trabajaremos sobre ramas creadas a partir de la rama <strong>"develop"</strong> con el prefijo "<strong>feature</strong>" (por ejemplo, <strong>"feature-captcha_en_registro"</strong>). Pujaremos nuestros cambios únicamente a esa rama, permitiendo así que el resto del equipo pueda revisarlos o mandarnos parches, si hemos pedido ayuda. Si el feedback recibido sobre nuestros parches es positivo, mezclaremos nuestra rama en "<strong>develop"</strong>.</p>

@tobifjellner Yes, indeed. I'm using es_ES.

#4 @marcelo2605
6 months ago

I tested the script below using WordPress version 5.3, Twenty Twenty version 1.0 and site language es_ES. I couldn't find no error.

<?php echo wptexturize( '<p>A "continuación", para "desarrollar". Nuevas ("funcionalidades")</p>' ); ?>

#5 @tobifjellner
6 months ago

Are the quotation marks in the initial sample actually located "on the other side" of a html tag? In other words, they are all located between a (closing) html tag and some kind of punctuation...

#6 @alexandernst
6 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I beg a pardon, my fault. I just did another test ( https://97563.home.blog/2019/12/10/test/ ). The problem seems to be caused by the "Scrawl" theme. I should fill a bug with Automattic.

#7 @SergeyBiryukov
6 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

Thanks for the follow-up!

#8 @alexandernst
5 months ago

@SergeyBiryukov I was wondering, since the Scrawl theme is created by Automattic, which is the entity behind WordPress (among others), maybe this bug is actually valid and should be reopened? If it isn't, where can I report a bug in order to get this bug fixed?

#9 @tobifjellner
5 months ago

Automattic and WordPress are two separate entities, although Automattic uses WordPress A LOT, and also contributes to WordPress A LOT. But the Scrawl theme is NOT part of WordPress. So, if there's a problem with this theme, then it would need to be reported to the theme authors/maintainers. Theme Scrawl is not included under https://github.com/Automattic/themes (in which case an issue under that repo would have been a suitable next step).
So best place to report an issue would probably be in the support forum for the theme itself: https://wordpress.org/support/theme/scrawl/

If you can verify that this bug is still present while using one of the Default Themes, like TwentySeventeen, TwentyTwenty, then this bug should be reopened.

Note: See TracTickets for help on using tickets.