WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#49054 closed enhancement (duplicate)

Introduce Left-Hand Navigation Menu Headers and Zones

Reported by: crdunst Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description

First time posting, please be kind :) I've been meaning to drop by with some feedback for a while. Feel free to move, reword, split out or delete this ticket if the format is wrong.

I'm primarily a developer, but with a background in UI design. I've been building with WP for 8 years, and work with client sites day-to-day when they're loaded with plugins, rather than 'vanilla' installs.

The plugin architecture is great, but numerous plugins can mean numerous left menu options for site-owners, interspersed with post type links. This can quickly get out-of-hand, and overwhelming for end-users.

Of course every plugin author thinks that their plugin warrants prominence. I'm looking at you SEO and Analytics plugins.

Menu Zones:

1) Have 'zones' of menus with headers, all on the left menu, based on function. So a heading of Content with post type links underneath (pages, posts, plus custom post types).

Then Settings with 'Tools', 'Plugins', 'Settings' etc underneath.

Lastly, a Plugins header where SEO plugin authors, slider authors and such can drop their links.

To be clear, this is simply introducing headers between the left-menu links.

2) Restrict or Guide placement in the correct zone.

Theme developers should be able to place left-menu links in any category. They know their theme best.

It's difficult to programatically restrict plugin authors to 'zones', but establishing the convention is a start. The plugin approval process might choose to reject an SEO plugin for placing their link in the 'Content' zone, but allow an Events plugin to place a link there.

Bonus: Top Navigation

Don't allow plugin authors to place links in the top nav (again, SEO and Analytics plugins are the biggest culprits). This just breaks the concept of everything on the left, and the left-to-right direction of 'select, edit, publish'.

The top menu can easily become overwhelmed given the text is horizontal.

Change History (6)

#1 @crdunst
5 months ago

  • Component changed from General to Menus
  • Version set to 5.3.2

#2 @knutsp
5 months ago

  • Component changed from Menus to Administration
  • Focuses administration added
  • Version 5.3.2 deleted

Hello @crdunst

Welcome to Trac and thanks for the ticket and suggestion.

Related: #47012

#3 @crdunst
5 months ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

Related: #47012

Some fantastic suggestions in there.

My quick suggestion feels like I've brought some supermarket cupcakes to the Great British Bake Off :)

I'll (try) to close my ticket, it looks like the issue is in hand.

Last edited 5 months ago by crdunst (previous) (diff)

#4 @knutsp
5 months ago

  • Keywords close removed
  • Resolution invalid deleted
  • Status changed from closed to reopened

#5 @knutsp
5 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #47012.

#6 @netweb
5 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.