WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#49649 closed defect (bug) (invalid)

problems with "Twenty Fifteen" theme

Reported by: stingpin Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.2
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

I have a couple of bugs to report.

In the customization section, it instructs me to make a header image 954 x 1300 pixels. I suspect those are not the dimensions intended by the designer, but they're the ones that the theme enforces. The result is a huge graphic off to the left side, running off the page and overlapping text. See attached screen shot.

What I wanted to do was run a graphic along the top above the blog posts. Is this not possible?

Also, the page doesn't display properly in the customization window. The left sidebar appears running across the entire page, with the blog posts under it. See attached screen shot.

Attachments (2)

Screen Shot 2020-03-13 at 5.14.04 PM.png (415.5 KB) - added by stingpin 2 months ago.
How the header graphic is displaying
Screen Shot 2020-03-15 at 10.50.14 AM.png (554.1 KB) - added by stingpin 2 months ago.
How the page displays in the cusomization window

Download all attachments as: .zip

Change History (6)

@stingpin
2 months ago

How the header graphic is displaying

@stingpin
2 months ago

How the page displays in the cusomization window

#1 @sabernhardt
2 months ago

  • Component changed from General to Bundled Theme

Hi @stingpin and thanks for the report!

That actually should be the intended behavior for a header (background) image in Twenty Fifteen. It's best for adding subtle texture images and such, not so great for something to feature prominently.

When the screen size or browser width is 954 pixels or narrower (as you see in the customizer), the header bar is across the top of the page. At 955 pixels and wider, the header section moves to the left side, so the designers wanted the background image to have 1300 pixels to cover the window's height there.

Twenty Sixteen (and various other themes) may give the header image more prominence, and Twenty Fifteen files could be modified in a custom child theme to place an image above the posts.

In your case, though, I'd recommend making that image your site logo instead (under Site Identity in the customizer) and unchecking the "Display Site Title and Tagline" box.

#2 @stingpin
2 months ago

Hi,
Thanks. But I'm not finding anything labeled "Site Identity." Customize is giving me Site Title & Tagline, Colors, Header Image, Background Image, Navigation, Widgets, and Static Front Page.

#3 @tobifjellner
2 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi @stingpin
Core Trac is the system where we collect confirmed bugs and follow-up on the fixes for WordPress core.
In this case, it seems to be more that you aren't fully sure how to achieve what you want to do. The channel for that would be the support forum for this theme https://wordpress.org/support/theme/twentyfifteen/ or perhaps the more general "Fixing WordPress" forum https://wordpress.org/support/forum/how-to-and-troubleshooting/

I'll close this ticket for now. If you actually find that there is a bug, then you can come back here and open a new ticket with steps for how to reproduce the bug.

#4 @SergeyBiryukov
2 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.