WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 4 months ago

#49827 closed defect (bug) (invalid)

WP 5.4 Block Editor width

Reported by: mbeerli Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4
Component: Editor Keywords:
Focuses: Cc:

Description

When in a post (edit mode) the title is quite wide, the below blocks are very narrow and I do not see any option to widen all Blocks. This must be a bug.

Attachments (1)

Screenshot from 2020-04-06 07-11-15.png (531.2 KB) - added by mbeerli 20 months ago.
block width in edit mode

Download all attachments as: .zip

Change History (4)

@mbeerli
20 months ago

block width in edit mode

#1 @SergeyBiryukov
20 months ago

  • Component changed from General to Editor

#2 @Otto42
20 months ago

It is not a bug, the default width of the editor space is 580 pixels. If the space needs to be larger because the theme provides a wider area on the page, then the theme itself should style the editor to be wider using editor-styles.

https://developer.wordpress.org/block-editor/developers/themes/theme-support/

Changing the width of the editor is specifically mentioned:

https://developer.wordpress.org/block-editor/developers/themes/theme-support/#changing-the-width-of-the-editor

#3 @sabernhardt
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The default content block width on larger screens is slightly wider at 610px now, but the title block will not match that for every theme. Although I do see your theme (Graphene) matches the title and content blocks at 750 pixels wide.

Closing as not-a-bug.

Note: See TracTickets for help on using tickets.