WordPress.org

Make WordPress Core

#50536 closed defect (bug) (fixed)

Fix link colors for admin schemes that personalize it using the $link SASS variable

Reported by: youknowriad Owned by: youknowriad
Milestone: 5.5 Priority: normal
Severity: normal Version: 5.5
Component: Administration Keywords: needs-patch
Focuses: css Cc:

Description

Custom link colors used on admin schemes are broken in some instances. They are using the default link color.

  • For button links
  • And a specific case in the customizer

Attachments (5)

Capture d’écran 2020-07-02 à 4.35.33 PM.png (7.5 KB) - added by youknowriad 17 months ago.
Capture d’écran 2020-07-02 à 4.35.22 PM.png (120.3 KB) - added by youknowriad 17 months ago.
The close link was broken.
50536 destructive action wp 5.4 Ectoplasm.png (174.5 KB) - added by afercia 17 months ago.
Destructive action in WordPress 5.4: red (Ectoplasm color scheme)
50536 destructive action wp trunk Ectoplasm.png (219.7 KB) - added by afercia 17 months ago.
Destructive action in WordPress trunk: blue (Ectoplasm color scheme)
restore-remove-colors.diff (465 bytes) - added by youknowriad 17 months ago.
Fix remove link colors for admin schemes

Download all attachments as: .zip

Change History (14)

@youknowriad
17 months ago

The close link was broken.

This ticket was mentioned in PR #378 on WordPress/wordpress-develop by youknowriad.


17 months ago

  • Keywords has-patch added

https://core.trac.wordpress.org/ticket/50536

This Pull Request is for code review only. Please keep all other discussion in the Trac ticket. Do not merge this Pull Request. See [GitHub Pull Requests for Code Review](https://make.wordpress.org/core/handbook/contribute/git/github-pull-requests-for-code-review/) in the Core Handbook for more details.

#2 @youknowriad
17 months ago

  • Owner set to youknowriad
  • Status changed from assigned to accepted

#3 @youknowriad
17 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 48332:

Administration: Fix link colors for admin schemes that personalize it using the $link SASS variable.

The new "moderne" admin scheme color personalizes the link color using the $link SASS variable.
The link color doesn't apply consistently in the admin to all links, especiall button links.

Fixes #50536.

#4 @afercia
17 months ago

  • Keywords needs-patch added; has-patch removed
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 5.4 to trunk

[48332] introduced a regression: some "destructive action" buttons aren't red any longer, in all the color schemes.

This happens because now button-link from the color schemes overrides button-link-delete.

Red destructive action controls are a well established convention in core, as any potentially action that deletes content should be visually well distinguished.

See attached screenshot for the destructive action in the Widgets. Happens also in the customizer.

Worth also reminding that when changing variables in the _admin.scss file, the change will likely impact plugins that extend the color schemes. At the very least, this change should have a dev-note.

Reopening as the red color for destructive action should be restored.

@afercia
17 months ago

Destructive action in WordPress 5.4: red (Ectoplasm color scheme)

@afercia
17 months ago

Destructive action in WordPress trunk: blue (Ectoplasm color scheme)

#5 @youknowriad
17 months ago

Good catch @afercia I'll take a look shortly.

@youknowriad
17 months ago

Fix remove link colors for admin schemes

#6 @youknowriad
17 months ago

@afercia the last patch should solve the issue. Would you mind checking?

#7 @afercia
17 months ago

@youknowriad I'm afraid I'm a bit busy, Beta 1 day :)

Given this is a new feature introduced in this release cycle, I think it can be addressed also during Beta.

#8 @youknowriad
17 months ago

Thanks for the notice, I'll find someone to confirm the fix and see if I can commit it before beta 1

#9 @youknowriad
17 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 48376:

Administration: Fix remove links color.

Fix regression introduced in [48332] where the specificity
of the admin scheme link colors was higher than the remove link colors.

Props afercia.
Fixes #50536.

Note: See TracTickets for help on using tickets.