WordPress.org

Make WordPress Core

Opened 15 months ago

Closed 8 months ago

#50540 closed defect (bug) (duplicate)

Export strips HTML tags from Post Titles

Reported by: MadtownLems Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Export Keywords:
Focuses: Cc:

Description

As far as I can tell, html tags are permissible in Post Titles. For example, we use post title such as "Sea thrift, <em>Armeria maritima</em>" to properly designate the scientific name of the plant.

When performing a standard Export, these tags are stripped and not present in the export file.

It looks like do_export uses the 'the_title_rss' filter, which strips all tags. If html tags (or a subset of them) are permissible in Post Titles, then I believe these shouldn't be stripped out when doing an export.

Change History (2)

#1 @donmhico
15 months ago

  • Keywords 2nd-opinion added

These make sense to me but before we create a patch for this I would like some more input from other devs.

#2 @pento
8 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 5.4.2 to 2.5

Thanks for the bug report, @MadtownLems!

I'm going to close this issue as a duplicate of #52250, since there's a patch there which fixes this issue.

Note: See TracTickets for help on using tickets.