WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#50609 closed defect (bug) (fixed)

5.5 beta - Archives widget is missing its closing tag

Reported by: joyously Owned by: SergeyBiryukov
Milestone: 5.5 Priority: normal
Severity: normal Version: 5.5
Component: Widgets Keywords: has-patch
Focuses: Cc:

Description

The Archive widget changed (I think to get a unique ID, not sure), and now the after_widget parameter is not output.

I've attached a screenshot of WP 5.4.2 on the left and WP 5.5beta on the right, and that's the only difference. You can see that the styling indicates that the widgets that follow it are inside it.

Attachments (2)

WP5.4.2-left-and-WP5.5beta-right-archive-widget.jpg (252.3 KB) - added by joyously 3 months ago.
WP 5.4.2 is on the left and WP 5.5 beta is on the right. Note the Meta widget and Text widget are inside the Archives widget on the right.
50609.patch (411 bytes) - added by mukesh27 3 months ago.
Patch.

Download all attachments as: .zip

Change History (6)

@joyously
3 months ago

WP 5.4.2 is on the left and WP 5.5 beta is on the right. Note the Meta widget and Text widget are inside the Archives widget on the right.

#1 @SergeyBiryukov
3 months ago

  • Milestone changed from Awaiting Review to 5.5

#2 @mukesh27
3 months ago

  • Keywords needs-patch added

It's regression of this [48349] changeset.

Last edited 3 months ago by SergeyBiryukov (previous) (diff)

@mukesh27
3 months ago

Patch.

#3 @mukesh27
3 months ago

  • Keywords has-patch added; needs-patch removed

#4 @SergeyBiryukov
3 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 48409:

Widgets: Correct the logic for displaying the after_widget parameter of the Archives widget.

Follow-up to [48349].

Props mukesh27, joyously.
Fixes #50609.

Note: See TracTickets for help on using tickets.