WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#50788 closed defect (bug) (fixed)

"PHP Update Required" dashboard box title is right-aligned

Reported by: SergeyBiryukov Owned by: SergeyBiryukov
Milestone: 5.5 Priority: normal
Severity: normal Version: 5.5
Component: Administration Keywords: has-screenshots has-patch
Focuses: ui, css Cc:

Description

As noted by @TimothyBlynJacobs on Slack, the "PHP Update Required" title is now right-aligned.

This is a regression in trunk, see the screenshots.

Additionally:

  • The "Learn more" button has some extra bottom padding, due to removing !important from here in [48129]:
    .postbox .inside > p:last-child,
    .rss-widget ul li:last-child {
        margin-bottom: 1px !important;
    }
    
  • The vertical alignment on that button looks off.

Attachments (4)

50788.png (13.1 KB) - added by SergeyBiryukov 3 months ago.
50788.WP54.png (12.8 KB) - added by SergeyBiryukov 3 months ago.
In WordPress 5.4
50788.diff (597 bytes) - added by whyisjake 3 months ago.
Screen Shot 2020-07-27 at 4.03.15 PM.png (95.3 KB) - added by whyisjake 3 months ago.
Fix for both the headline and the bottom margin.

Download all attachments as: .zip

Change History (8)

@SergeyBiryukov
3 months ago

@SergeyBiryukov
3 months ago

In WordPress 5.4

@whyisjake
3 months ago

@whyisjake
3 months ago

Fix for both the headline and the bottom margin.

#1 @whyisjake
3 months ago

  • Keywords has-patch added

#2 @SergeyBiryukov
3 months ago

Instead of adding more styles, I'd rather restore the removed !important piece here, since it seems that could also affect other things.

Could we track down the commit that made the title right-aligned?

#3 @sabernhardt
3 months ago

The alignment is from [48373], using CSS flexbox on the heading for edit-box links.

.postbox-header .hndle {
	flex-grow: 1;
	/* Handle the alignment for the configurable dashboard widgets "Configure" edit-box link. */
	display: flex;
	justify-content: space-between;
	align-items: center;
}

#4 @SergeyBiryukov
3 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 48671:

Administration: Correct alignment of the "PHP Update Required" dashboard box title.

Restore one instance of !important CSS rule for backward compatibility.

Follow-up to [48129], [48373].

Props whyisjake, sabernhardt, TimothyBlynJacobs, SergeyBiryukov.
Fixes #50788.

Note: See TracTickets for help on using tickets.