WordPress.org

Make WordPress Core

#51114 closed defect (bug) (duplicate)

Wp 5.5 bug: Cannot delete multiple users

Reported by: quantum_leap Owned by:
Milestone: Priority: normal
Severity: major Version: 5.5
Component: Users Keywords:
Focuses: Cc:

Description

After updating to WP 5.5, I can't delete multiple users. I think there is something wrong with the wpnonce response?

Steps to reproduce:

1) Clean WP install with no plugin and default theme.
2) Create 3 test subscriber users
3) Try deleting all of them at once from the admin (not one by one)
4) I was expecting a confimation message for the users' deletion, instead, you get the message "The link you followed has expired. Try again". When you try again, you get the message "The link you followed has expired."
5) Delete users, and downgrade to previous WP version 5.4.2
6) Recreate the users
7) Try to bulk delete them
8) Users get deleted as expected

Change History (3)

#1 @justinahinon
11 months ago

Hey @quantum_leap. Welcome to Trac and thanks for opening this.

I can confirm I can effectively reproduce the issue on WordPress 5.5 and that it's working correctly 5.4.2.

Exploring to see where this was introduced.

#2 @justinahinon
11 months ago

So, looks like this happens very randomly on 5.5. Not seeing any obvious reason for that now.

#3 @SergeyBiryukov
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #50882.

Note: See TracTickets for help on using tickets.