WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#51424 closed defect (bug) (invalid)

Deprecated: media_buttons_context is deprecated since version 3.5.0! Use media_buttons instead.

Reported by: sweetandmasala Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: close
Focuses: Cc:

Description

Deprecated: media_buttons_context is deprecated since version 3.5.0! Use media_buttons instead.

I am getting this error after the most recent update and I cannot insert pictures into my post. How do I fix this?

Change History (2)

#1 @sabernhardt
7 months ago

  • Keywords close added

@sweetandmasala Please use the support forums for help with your site.

The deprecated media_buttons_context would be located in one of your activated plugins (or possibly the theme).

Try deactivating WP Ultimate Recipe first, as I think that's most likely the culprit. Its authors recommend migrating to their newer plugin WP Recipe Maker.

I noticed another error above a recipe (on the site's front end) that was caused by WP Ultimate Recipe:
Notice: Trying to access array offset on value of type bool in .../wp-content/plugins/wp-ultimate-recipe/helpers/models/recipe.php on line 254

#2 @SergeyBiryukov
7 months ago

  • Component changed from General to Media
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there, welcome to WordPress Trac!

I'm sorry to hear you are having issues with your website. Please note that this Trac is used for enhancements and bug reporting for the WordPress core software, not for individual support questions.

As noted above, please try the support forums to get help with your site: https://wordpress.org/support/forums/.

Last edited 7 months ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.