WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 5 months ago

#51600 closed defect (bug) (invalid)

Outside email accept/ email validation issue.

Reported by: jigar bhanushali Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: General Keywords: has-patch needs-testing reporter-feedback close
Focuses: administration, privacy Cc:

Description

User notification sent when users try to send export personal data and erase personal data requests using unknown(non-register) email.

Export Personal Data: {site_url}/wp-admin/export-personal-data.php
Erase Personal Data: {site_url}/wp-admin/erase-personal-data.php

Attachments (1)

51600.patch (1.3 KB) - added by jigar bhanushali 8 months ago.

Download all attachments as: .zip

Change History (7)

#1 @garrett-eclipse
8 months ago

Hello @jigar-bhanushali thanks for the ticket and patch. If I understand correct you're indicating an email is sent even if a user isn't associated to said email. If so then that's actually expected behaviour as commenters don't require an account in most cases but as they're supplying their personal information we need a way to export/erase their data as well. There's been some discussion in providing better messaging or suppressing the request when there's no data associated to the email and would make more sense to do a check on if there's data associated over if there's a user associated.

#2 @hellofromTonya
8 months ago

  • Keywords reporter-feedback added

This ticket was mentioned in Slack in #core-privacy by hellofromtonya. View the logs.


8 months ago

#4 @garrett-eclipse
8 months ago

  • Keywords close added
  • Version changed from trunk to 4.9.6

Bumping off trunk as this has been the behaviour since 4.9.6. Happy to discuss further @jigar-bhanushali but am going to label as an item to potentially close.

#5 @hellofromTonya
6 months ago

Hello @jigar-bhanushali and Welcome to WordPress Trac,

Does this problem still exist for you? If yes, please provide feedback to @garrett-eclipse's question for us to further investigate.

#6 @hellofromTonya
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket. However, if the problem persists, please reopen and provide more information to help us further investigate.

Note: See TracTickets for help on using tickets.