WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#52073 closed defect (bug) (fixed)

Text Widget has no editable fields in Accessibility Mode

Reported by: MadtownLems Owned by: joedolson
Milestone: 5.7 Priority: normal
Severity: normal Version: 5.6
Component: Widgets Keywords: has-patch commit
Focuses: accessibility Cc:

Description

To reproduce:

Place a text widget in a sidebar.
Enable Accessibility Mode from wp-admin/widgets.php
Click 'Edit' on your text widget.

What I expect to happen:
Have a form to edit the text of the widget as well as the location of the widget

What actually happens:
I am given a form choose the location of the widget, but not the actual text

Change History (21)

This ticket was mentioned in Slack in #accessibility by madtownlems. View the logs.


4 months ago

#2 @alexstine
4 months ago

  • Focuses accessibility added
  • Owner set to alexstine
  • Status changed from new to accepted

#3 @alexstine
4 months ago

Hello @MadtownLems ,

Thanks for the report, I can replicate the same.

It looks like this is caused by Tiny MCE not being implemented on the accessible view for widgets. There is a function that checks text widgets, which I've linked below. Basically if the text field is empty which it would be in newly added text widgets, it hides the fields that way legacy textarea can't be edited.

https://developer.wordpress.org/reference/classes/wp_widget_text/is_legacy_instance/

What might eventually happen is the accessible view could be phased out and the normal view be made more accessible. However this is still very much up for discussion with the accessibility team.

For now, you can edit the Text widgets content from the normal view. It has a Title field and then the Text contains Tiny MCE editor.

Hope this helps.

Thanks.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


4 months ago

#5 @ryokuhi
4 months ago

  • Milestone changed from Awaiting Review to 5.6.1

Hello @MadtownLems and thanks for reporting the issue.
It was discussed today during the weekly accessibility team's bug scrub.
After some quick testing, the team agreed this is probably a regression from 5.5 and agreed to move it to the 5.6.1 release, so that it can be fixed as soon as possible.

This ticket was mentioned in PR #828 on WordPress/wordpress-develop by alexstine.


4 months ago

  • Keywords has-patch added

#7 @alexstine
4 months ago

  • Keywords needs-testing added

PR is ready for review. Fixed one bug causing the editor to not load.

#8 @Hareesh Pillai
3 months ago

Thanks for the patch.
The suggested solution works as expected. I'm able to edit the widget title as well as content in the Accessibility Mode.

This ticket was mentioned in Slack in #accessibility by alexstine. View the logs.


3 months ago

#10 @alexstine
3 months ago

  • Milestone changed from 5.6.1 to 5.7

This ticket was mentioned in Slack in #core by monikarao. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by dariak. View the logs.


3 months ago

#13 @dariak
3 months ago

First I have reproduced the bug in WP 5.6 by adding Text widget in Sidebar and Footer and viewing it in Accessibility Mode.

I have re-tested PR by installing it in dev environment and executing the following:

  • added Text widget in Footer
  • clicked to enable Accessibility Mode on widget page
  • checked that Text field is available for editing
  • made changes in Text field and saved them
  • changes are available in Preview
  • activated theme which supports Sidebar
  • added Text widget in Sidebar
  • clicked to enable Accessibility Mode on widget page
  • checked that Text field is available for editing
  • made changes in Text field and saved them
  • changes are available in Preview

PR is tested successfully.

#14 @hellofromTonya
3 months ago

  • Keywords needs-testing removed

As noted, Daria was able to reproduce the problem and validated that the PR does it resolve it with the expected results. Removing the needs-testing keyword.

I think this ticket is now ready for commit. @alexstine do you agree? Is there anything else this ticket needs before making it a commit candidate?

#15 @alexstine
3 months ago

@hellofromTonya I agree, all good.

#16 @hellofromTonya
3 months ago

  • Keywords commit added

Awesome. Marking this ticket ready for commit.

#17 @joedolson
3 months ago

  • Owner changed from alexstine to joedolson
  • Status changed from accepted to assigned

This ticket was mentioned in Slack in #core-committers by joedolson. View the logs.


3 months ago

#19 @joedolson
3 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [49973]

#20 @sabernhardt
3 months ago

Since this is ready before the minor release, could it be backported for 5.6.1?

Note: See TracTickets for help on using tickets.