WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#52080 closed defect (bug) (duplicate)

Un-expected leaving prompt in classic editor

Reported by: kevin940726 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.6
Component: General Keywords:
Focuses: Cc:

Description

Originally posted in the support forum: Leave / Stay on Page Dialogue.

WordPress version: 5.6
WooCommerce version: 4.8.0

On the 5.6 version of WordPress, leaving a page with classic editor will prompt the users with a confirmation dialog. It's not happening on the previous version of WordPress.

Steps to reproduce:

  • On a clean WordPress installation
  • Install and active WooCommerce plugin
  • Create a product and publish it
  • Edit the product
  • Exit the page without doing any changes

Not sure if it's related to WooCommerce only or a bug in core instead, because it's not happening in my other site with WordPress 5.4.2 and the same version of WooCommerce.

I'm able to pin-point the line that causes this error: https://core.trac.wordpress.org/browser/tags/5.6/src/js/_enqueues/vendor/jquery/jquery.js#L5601

Seems like has something to do with the recent jQuery update.

Attachments (1)

Kapture 2020-12-15 at 15.57.08.gif (4.0 MB) - added by kevin940726 3 months ago.
Recording of the reproduction steps

Change History (2)

@kevin940726
3 months ago

Recording of the reproduction steps

#1 @kevin940726
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #52038.

Note: See TracTickets for help on using tickets.