WordPress.org

Make WordPress Core

Opened 6 weeks ago

Closed 3 weeks ago

Last modified 13 days ago

#52957 closed defect (bug) (reported-upstream)

Categories dropdown overlapping on admin block-patterns area

Reported by: ramizmanked Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7
Component: Editor Keywords:
Focuses: ui, accessibility, css Cc:

Description

When you scroll through block patterns list (Add block -> Patterns), Categories dropdown is overlapping block search bar and block type tabs above (screencast attached).

Attachments (1)

block-pattern-categories-dropdown-overlap.webm (1.9 MB) - added by ramizmanked 6 weeks ago.
Screencast that replicates issue

Download all attachments as: .zip

Change History (13)

@ramizmanked
6 weeks ago

Screencast that replicates issue

#1 @sabernhardt
6 weeks ago

  • Component changed from Formatting to Editor
  • Focuses administration removed
  • Type changed from enhancement to defect (bug)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


5 weeks ago

#3 @paaljoachim
5 weeks ago

Hi @ramizmanked

First update WordPress to 5.7.

1- Deactivate all plugins on the site that has the problem and see if the error goes away. If it does then we know it is a plugin conflict. Turn on each plugin at a time and see when the error returns. When you figure out which plugin that has the error. Contact the plugin developer by going to their WordPress plugin repository and write a post in the support forum.

2- If the error still remains after turning off all the plugins then switch to a default theme such as Twenty Twenty or Twenty Twenty One. If the error goes away then it seems like a theme problem. Contact the theme creator.

If the error is still seen after deactivating all plugins and switching to a default theme.
Then let us know which browser you are using.

An example.
I tested with WordPress 5.7. Twenty Twenty One theme. Gutenberg plugin 10.3.2.
In Chrome (also tested in Safari). I clicked the inserter. Clicked the pattern drop down. Then tried to scroll, but was not able to.
Since I tested Chrome and Safari and could not encounter the error. It seems likely that you have experienced a plugin error.

Last edited 5 weeks ago by paaljoachim (previous) (diff)

#4 @ramizmanked
4 weeks ago

Thanks, @paaljoachim!

I'll double check the issue with the steps you mentioned and let you know what I find. Thank you!

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


4 weeks ago

#6 @ramizmanked
3 weeks ago

@paaljoachim - The issue seems to be still exist with fresh WordPress install as well.

Here is my setup:

  • Browser: Google Chrome Version 89.0.4389.128
  • WordPress: 5.7.1
  • Active Theme: Twenty Twenty-One

My guess is the issue arise only after changing the Block Pattern category dropdown initially.

Here is the link to a quick screencast(https://vimeo.com/538046001) that replicates an issue.

#7 @paaljoachim
3 weeks ago

Thank you for the video @ramizmanked
I was able to repeat the bug and went ahead and made a Github issue for it here: https://github.com/WordPress/gutenberg/issues/30947

Have a great weekend!

#8 @ramizmanked
3 weeks ago

@paaljoachim Thanks a bunch!

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 weeks ago

#10 @ryokuhi
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

As a related issue was opened on Gutenberg's Repository, I'm closing this issue as reported upstream.

#11 @paaljoachim
2 weeks ago

Hey @ramizmanked

It looks like this might have been fixed in the Gutenberg plugin 10.5 RC.
https://github.com/WordPress/gutenberg/releases/tag/v10.5.0-rc.1

Retesting with WordPress 5.7.1. Gutenberg plugin 10.5 RC. Twenty Twenty One.

Following the procedure here: https://github.com/WordPress/gutenberg/issues/30947 I am not able to reproduce. Please retest and let us know.
Thank you!

#12 @paaljoachim
13 days ago

I went ahead and closed the Github Gutenberg issue. As I mentioned there. The issue can always be reopened if need be. Have a great day!

Note: See TracTickets for help on using tickets.