WordPress.org

Make WordPress Core

Opened 3 weeks ago

Closed 3 weeks ago

#53042 closed defect (bug) (worksforme)

Updates for older branches missing when checking for updates

Reported by: Ov3rfly Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

API response for core version currently only returns 5.7.1 but not available updates for older branches.

API response also should contain e.g. update files for 5.6.3 when queried from a 5.6.2 install. Similar within other older branches.

[15-Apr-2021 13:44:20 UTC] stdClass Object
(
    [updates] => Array
        (
            [0] => stdClass Object
                (
                    [response] => upgrade
                    [download] => https://downloads.wordpress.org/release/de_DE/wordpress-5.7.1.zip
                    [locale] => de_DE
                    [packages] => stdClass Object
                        (
                            [full] => https://downloads.wordpress.org/release/de_DE/wordpress-5.7.1.zip
                            [no_content] => 
                            [new_bundled] => 
                            [partial] => 
                            [rollback] => 
                        )

                    [current] => 5.7.1
                    [version] => 5.7.1
                    [php_version] => 5.6.20
                    [mysql_version] => 5.0
                    [new_bundled] => 5.6
                    [partial_version] => 
                )

            [1] => stdClass Object
                (
                    [response] => upgrade
                    [download] => https://downloads.wordpress.org/release/wordpress-5.7.1.zip
                    [locale] => en_US
                    [packages] => stdClass Object
                        (
                            [full] => https://downloads.wordpress.org/release/wordpress-5.7.1.zip
                            [no_content] => https://downloads.wordpress.org/release/wordpress-5.7.1-no-content.zip
                            [new_bundled] => https://downloads.wordpress.org/release/wordpress-5.7.1-new-bundled.zip
                            [partial] => 
                            [rollback] => 
                        )

                    [current] => 5.7.1
                    [version] => 5.7.1
                    [php_version] => 5.6.20
                    [mysql_version] => 5.0
                    [new_bundled] => 5.6
                    [partial_version] => 
                )

        )

    [last_checked] => 1618494260
    [version_checked] => 5.6.2
    [translations] => Array
        (
        )

)

Change History (5)

#1 @dd32
3 weeks ago

Hi @Ov3rfly,

Currently the WordPress.org API's only offer the latest version of WordPress for manual updates, with older branches receiving automatic updates.

Running an older version of WordPress is not officially supported, with them receiving security updates purely out of interest in the ongoing security of sites, not that we encourage users to continue to run those versions, or to provide a choice of not running the latest branch.

At present during the 5.7.1/5.6.3 release, due to network constraints some sites may not currently be receiving automatic updates but will in the coming hours.

This ticket was mentioned in Slack in #meta by afilatev. View the logs.


3 weeks ago

#3 follow-up: @Ov3rfly
3 weeks ago

Ok thanks for information. As no site in older branches here has received automatic updates until now, I have tracked down the current API response and opened this ticket.

According to stats API https://api.wordpress.org/stats/wordpress/1.0/ more than 2/3 of installs appear to run older branches of WordPress.

#4 @Ov3rfly
3 weeks ago

API response for core updates now also returns updates for older branches.

#5 in reply to: ↑ 3 @dd32
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Replying to Ov3rfly:

Ok thanks for information. As no site in older branches here has received automatic updates until now

It was progressively enabled due to network capacity limitations, I'm guessing that the sites you were looking at were most likely in one of the last groups to be enabled (or, the request wasn't from a WordPress client, in which case it definitely was in the last group) as I know older branches were most definately getting the updates :)

As you've noted, since my last comment all sites would've got the autoupdate.

I'm going to close this ticket as worksforme as a) The API is serving all autoupdates now (and was working as intended) and b) as outlined above, I don't think offering a manual update to a not-the-latest release is something we should be encouraging (Exception to that: When we increase PHP requirements, older PHP versions do currently get an update notification to an older WP branch that their PHP is still supported on)

I'll mention it to the #core-auto-updates slack channel to see if anyone feels strongly enough against that though, and if so, can re-open / create a ticket for it.

Note: See TracTickets for help on using tickets.