Make WordPress Core

Opened 3 years ago

Closed 2 weeks ago

#54126 closed defect (bug) (wontfix)

Twenty Twenty: Left and right image alignment issue in front side

Reported by: aezazshekh's profile aezazshekh Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch has-screenshots needs-testing close
Focuses: css Cc:

Description

In the twentytwenty theme, when we give alignment left and right to the image from the backend, the design is breaking due to some properties on that image in the front side.

Attachments (4)

54126.diff (730 bytes) - added by aezazshekh 3 years ago.
Create a Patch
left-alignment.png (66.8 KB) - added by aezazshekh 3 years ago.
Screenshot of image left alignment
right-alignment.png (60.3 KB) - added by aezazshekh 3 years ago.
Screenshot of image right alignment ( image position distortion )
left_right_image.jpg (69.7 KB) - added by aezazshekh 3 years ago.
This left & right alignment issue was solved by modifying a few css properties. The issue is solved, its screenshot is attached.

Download all attachments as: .zip

Change History (13)

@aezazshekh
3 years ago

Create a Patch

#1 @aezazshekh
3 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
3 years ago

  • Component changed from Themes to Bundled Theme
  • Summary changed from Left and right image alignment issue in front side in twentytwenty theme to Twenty Twenty: Left and right image alignment issue in front side

#3 @SergeyBiryukov
3 years ago

  • Keywords needs-screenshots added

Hi there, welcome to WordPress Trac! Thanks for the report.

Could you share some screenshots of the issue?

It looks like the lines being patched here were added in [46711].

@aezazshekh
3 years ago

Screenshot of image left alignment

@aezazshekh
3 years ago

Screenshot of image right alignment ( image position distortion )

#4 @sabernhardt
3 years ago

Looking at PR 994, the absolute positioning seems to be an intentional design choice since the beginning of the theme.

The current styling is not appropriate for all images, but anyone who has aligned an image block with Twenty Twenty likely wants to keep it positioned that way.

You might appreciate the layout by placing the image inside a group block.

@aezazshekh
3 years ago

This left & right alignment issue was solved by modifying a few css properties. The issue is solved, its screenshot is attached.

#5 @sabernhardt
2 years ago

  • Keywords has-screenshots added; needs-screenshots removed

Related: #48718

#6 @karmatosed
5 weeks ago

  • Keywords needs-testing added

#7 @karmatosed
5 weeks ago

  • Milestone changed from Awaiting Review to Future Release

#8 @karmatosed
2 weeks ago

  • Keywords close added

I second that this seems to be a design decision at the time of the theme being created. As a result I would recommend this for now is closed. Thank you everyone.

#9 @karmatosed
2 weeks ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

As suggested I am going to close this for now, thank you everyone.

Note: See TracTickets for help on using tickets.