WordPress.org

Make WordPress Core

Opened 12 days ago

Closed 12 days ago

Last modified 11 days ago

#54502 closed task (blessed) (fixed)

Pin NodeJS 14.x in the `.nvmrc` file

Reported by: desrosj Owned by: desrosj
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

NodeJS 16.x is now considered the latest LTS version as of 2021-10-26. If a contributor runs nvm use or nvm install, version 16.x will be downloaded and installed.

While it appears that npm run build and other scripts still work as expected, NPM version 7 introduces a new format for package-lock.json files. Contributors will notice unintentional changes to that file. See #52951 for updating the lock file format.

Since Gutenberg now enforces version 14 (see GB-36744), I think it makes sense to change Core's version as well, even if temporarily, until compatibility with NodeJS 16 for both Gutenberg and Core can be confirmed, and the package-lock.json for both repositories can be upgraded to v2 format at the same time.

Change History (2)

#1 @desrosj
12 days ago

  • Owner set to desrosj
  • Resolution set to fixed
  • Status changed from new to closed

In 52240:

Build/Test Tools: Specify NodeJS version 14.x in the .nvmrc file.

As of 2021-10-26, the LTS version of NodeJS is now 16.x.

This pins the 14.x version in the .nvmrc file to ensure contributors are able to contribute without issue until compatibility with version 16.x can be confirmed in both trunk and the Gutenberg repository on GitHub.

Fixes #54502.

This ticket was mentioned in Slack in #core by sergey. View the logs.


11 days ago

Note: See TracTickets for help on using tickets.