Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#54735 closed defect (bug) (duplicate)

get_sample_permalink unsets $post->filter even though this is a public property.

Reported by: herregroen's profile herregroen Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7.1
Component: General Keywords:
Focuses: Cc:

Description

The property should be set to null rather than being unset.

Unsetting it removes it entirely which means if it's later requested ( such as in WP_Post::__get ) this causes a notice to be thrown that the property doesn't exist.

Change History (2)

#1 @hellofromTonya
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hmm a duplicate of #54736. Closing.

#2 @hellofromTonya
2 years ago

  • Version changed from trunk to 2.7.1
Note: See TracTickets for help on using tickets.