Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54923 closed defect (bug) (duplicate)

English (UK) language selection shows wrong date format.

Reported by: sarumbear's profile sarumbear Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:

Description

When the Site Language is set to English (UK) the date format is not changed. It still shows in US format as in YYYY/MM/DD. It should be DD/MM/YYYY instead. (The Date format is set at j F Y.)

This can be confirmed on the the All Posts list and under the Time Zone section of the settings page.

If the Site Language is set to Francais or Afrikaans date is displayed correctly as DD/MM/YYYY. Strangely it reverts to the US format when English (South Africa) is selected even though it is the same locale as Afrikaans.

This bug exists on 5.8 as well.

Change History (1)

#1 @ocean90
2 years ago

  • Component changed from General to I18N
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.9 deleted

Hello @sarumbear, welcome to WordPress Trac!

Thanks for the report. This is a known issue and already tracked in #36259 therefore I'm going to close your ticket as a duplicate of it.

Note: See TracTickets for help on using tickets.