Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54960 closed defect (bug) (fixed)

Media Library Dragging Option Isn't Reflected

Reported by: muffinpeace's profile muffinpeace Owned by: joedolson's profile joedolson
Milestone: 5.9.1 Priority: normal
Severity: normal Version: 5.9
Component: Gallery Keywords: has-screenshots has-testing-info needs-testing
Focuses: ui, accessibility Cc:

Description

Dragging images to reorder or rearrange them on the Media Library doesn't get reflected as soon as you unpress the mouse key.

First start by adding any widget that can contain various images (Jetpack Slideshow or Gallery) and then proceeding to drag the images to organize them.

Screencast: https://d.pr/i/aI9Drd

Attachments (2)

gallery-issue.png (297.5 KB) - added by ravipatel 2 years ago.
You can see here JS isue when drag-drop images in gallery.
54960.patch (589 bytes) - added by ravipatel 2 years ago.
Patch for js issue which is defined in screenshort and after this code drag-drop working fine

Download all attachments as: .zip

Change History (13)

#1 @Boniu91
2 years ago

  • Keywords has-testing-info added

Thank you for the ticket! I'm able to reproduce this.

Steps to test

  1. Use WordPress 5.9
  2. Add new page
  3. Add gallery block
  4. Choose 3 different images and click on Create New Gallery
  5. Try to change the order of the images

This ticket was mentioned in Slack in #core-test by boniu91. View the logs.


2 years ago

#3 @SergeyBiryukov
2 years ago

  • Milestone changed from Awaiting Review to 5.9.1

@ravipatel
2 years ago

You can see here JS isue when drag-drop images in gallery.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


2 years ago

#5 @joedolson
2 years ago

  • Owner set to joedolson
  • Status changed from new to accepted

See also #53856.

@ravipatel
2 years ago

Patch for js issue which is defined in screenshort and after this code drag-drop working fine

#6 @Clorith
2 years ago

Looks like we might have two different issues discussed in this ticket.

The problem from the initial report is with the media modal, which was initially reported in #54902, and was caused by a jQuery UI regression, this has since been fixed in jQuery UI version 1.13.1, which will be included with the release of WordPress 5.9.1

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


2 years ago

#8 @joedolson
2 years ago

  • Keywords needs-testing added

If we can get confirmation that this is fixed in 5.9.1 by the jQuery UI version update, then let's close this.

@clorith You indicate that there might be two issues discussed in this ticket; can you clarify what the second one is? If it's the linked ticket, that's just a possibly related issue, and probably can be ignored if the jQuery UI update fixes this.

#9 @Clorith
2 years ago

Of course, sorry about the fuzzy response originally @joedolson :)

Yes the jQuery UI upgrade would fix this ticket.

Ticket #53856 seems unrelated to jQuery, the reporter there said they were running into the same problem in WP 5.8, and is also making a reference to an error that is unrelated to jQuery UI.

This ticket was mentioned in Slack in #accessibility by alexstine. View the logs.


2 years ago

#11 @joedolson
2 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Testing confirms fixed. Closing, fixed in r52648.

Note: See TracTickets for help on using tickets.