Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#55395 closed task (blessed) (fixed)

Update Twemoji for 6.0

Reported by: kraftbj's profile kraftbj Owned by: kraftbj's profile kraftbj
Milestone: 6.0 Priority: normal
Severity: normal Version:
Component: Emoji Keywords: needs-user-docs add-to-field-guide
Focuses: Cc:

Description

Twitter has released Twemoji 14.0 (and 14.0.1). We can upgrade to include the new Emoji 14 fun.

Previously #52852

This release will include a number of new emoji:

🫠 Melting Face
🫢 Face with Open Eyes and Hand Over Mouth
🫣 Face with Peeking Eye
🫡 Saluting Face
🫥 Dotted Line Face
🫤 Face with Diagonal Mouth
🥹 Face Holding Back Tears
🫱 Rightwards Hand
🫲 Leftwards Hand
🫳 Palm Down Hand
🫴 Palm Up Hand
🫰 Hand with Index Finger and Thumb Crossed
🫵 Index Pointing at the Viewer
🫶 Heart Hands
🫦 Biting Lip
🫅 Person with Crown
🫃 Pregnant Man
🫄 Pregnant Person
🧌 Troll
🪸 Coral
🪷 Lotus
🪹 Empty Nest
🪺 Nest with Eggs
🫘 Beans
🫗 Pouring Liquid
🫙 Jar
🛝 Playground Slide
🛞 Wheel
🛟 Ring Buoy
🪬 Hamsa
🪩 Mirror Ball
🪫 Low Battery
🩼 Crutch
🩻 X-Ray
🫧 Bubbles
🪪 Identification Card
🟰 Heavy Equals Sign
🫱🏻 Rightwards Hand: Light Skin Tone
🫱🏼 Rightwards Hand: Medium-Light Skin Tone
🫱🏽 Rightwards Hand: Medium Skin Tone
🫱🏾 Rightwards Hand: Medium-Dark Skin Tone
🫱🏿 Rightwards Hand: Dark Skin Tone
🫲🏻 Leftwards Hand: Light Skin Tone
🫲🏼 Leftwards Hand: Medium-Light Skin Tone
🫲🏽 Leftwards Hand: Medium Skin Tone
🫲🏾 Leftwards Hand: Medium-Dark Skin Tone
🫲🏿 Leftwards Hand: Dark Skin Tone
🫳🏻 Palm Down Hand: Light Skin Tone
🫳🏼 Palm Down Hand: Medium-Light Skin Tone
🫳🏽 Palm Down Hand: Medium Skin Tone
🫳🏾 Palm Down Hand: Medium-Dark Skin Tone
🫳🏿 Palm Down Hand: Dark Skin Tone
🫴🏻 Palm Up Hand: Light Skin Tone
🫴🏼 Palm Up Hand: Medium-Light Skin Tone
🫴🏽 Palm Up Hand: Medium Skin Tone
🫴🏾 Palm Up Hand: Medium-Dark Skin Tone
🫴🏿 Palm Up Hand: Dark Skin Tone
🫰🏻 Hand with Index Finger and Thumb Crossed: Light Skin Tone
🫰🏼 Hand with Index Finger and Thumb Crossed: Medium-Light Skin Tone
🫰🏽 Hand with Index Finger and Thumb Crossed: Medium Skin Tone
🫰🏾 Hand with Index Finger and Thumb Crossed: Medium-Dark Skin Tone
🫰🏿 Hand with Index Finger and Thumb Crossed: Dark Skin Tone
🫵🏻 Index Pointing at the Viewer: Light Skin Tone
🫵🏼 Index Pointing at the Viewer: Medium-Light Skin Tone
🫵🏽 Index Pointing at the Viewer: Medium Skin Tone
🫵🏾 Index Pointing at the Viewer: Medium-Dark Skin Tone
🫵🏿 Index Pointing at the Viewer: Dark Skin Tone
🫶🏻 Heart Hands: Light Skin Tone
🫶🏼 Heart Hands: Medium-Light Skin Tone
🫶🏽 Heart Hands: Medium Skin Tone
🫶🏾 Heart Hands: Medium-Dark Skin Tone
🫶🏿 Heart Hands: Dark Skin Tone
🤝🏻 Handshake: Light Skin Tone
🤝🏼 Handshake: Medium-Light Skin Tone
🤝🏽 Handshake: Medium Skin Tone
🤝🏾 Handshake: Medium-Dark Skin Tone
🤝🏿 Handshake: Dark Skin Tone
🫱🏻‍🫲🏼 Handshake: Light Skin Tone, Medium-Light Skin Tone
🫱🏻‍🫲🏽 Handshake: Light Skin Tone, Medium Skin Tone
🫱🏻‍🫲🏾 Handshake: Light Skin Tone, Medium-Dark Skin Tone
🫱🏻‍🫲🏿 Handshake: Light Skin Tone, Dark Skin Tone
🫱🏼‍🫲🏻 Handshake: Medium-Light Skin Tone, Light Skin Tone
🫱🏼‍🫲🏽 Handshake: Medium-Light Skin Tone, Medium Skin Tone
🫱🏼‍🫲🏾 Handshake: Medium-Light Skin Tone, Medium-Dark Skin Tone
🫱🏼‍🫲🏿 Handshake: Medium-Light Skin Tone, Dark Skin Tone
🫱🏽‍🫲🏻 Handshake: Medium Skin Tone, Light Skin Tone
🫱🏽‍🫲🏼 Handshake: Medium Skin Tone, Medium-Light Skin Tone
🫱🏽‍🫲🏾 Handshake: Medium Skin Tone, Medium-Dark Skin Tone
🫱🏽‍🫲🏿 Handshake: Medium Skin Tone, Dark Skin Tone
🫱🏾‍🫲🏻 Handshake: Medium-Dark Skin Tone, Light Skin Tone
🫱🏾‍🫲🏼 Handshake: Medium-Dark Skin Tone, Medium-Light Skin Tone
🫱🏾‍🫲🏽 Handshake: Medium-Dark Skin Tone, Medium Skin Tone
🫱🏾‍🫲🏿 Handshake: Medium-Dark Skin Tone, Dark Skin Tone
🫱🏿‍🫲🏻 Handshake: Dark Skin Tone, Light Skin Tone
🫱🏿‍🫲🏼 Handshake: Dark Skin Tone, Medium-Light Skin Tone
🫱🏿‍🫲🏽 Handshake: Dark Skin Tone, Medium Skin Tone
🫱🏿‍🫲🏾 Handshake: Dark Skin Tone, Medium-Dark Skin Tone
🫅🏻 Person with Crown: Light Skin Tone
🫅🏼 Person with Crown: Medium-Light Skin Tone
🫅🏽 Person with Crown: Medium Skin Tone
🫅🏾 Person with Crown: Medium-Dark Skin Tone
🫅🏿 Person with Crown: Dark Skin Tone
🫃🏻 Pregnant Man: Light Skin Tone
🫃🏼 Pregnant Man: Medium-Light Skin Tone
🫃🏽 Pregnant Man: Medium Skin Tone
🫃🏾 Pregnant Man: Medium-Dark Skin Tone
🫃🏿 Pregnant Man: Dark Skin Tone
🫄🏻 Pregnant Person: Light Skin Tone
🫄🏼 Pregnant Person: Medium-Light Skin Tone
🫄🏽 Pregnant Person: Medium Skin Tone
🫄🏾 Pregnant Person: Medium-Dark Skin Tone
🫄🏿 Pregnant Person: Dark Skin Tone

source: https://blog.emojipedia.org/twemoji-14-0-emoji-changelog/

Change History (15)

This ticket was mentioned in PR #2416 on WordPress/wordpress-develop by kraftbj.


2 years ago
#1

  • Keywords has-patch added

Adds Twemoji 14.0.1 support.
Update the regex (output of grunt precommit:emoji)
Updates the CDN URL to 14.0.1 (still needs uploading on the w.org side)
NEEDED: Detection script update.

Emoji 14 does not add any ZWJ-based emoji, unlike the past standards, so our script to detect needs a bit more work than usual. I didn't think about this and most of my computers are already upgraded to supported OS versions, so will get an old computer out of the closet to help figure out a good way to
detect it with as little change to the code as feasible.

Trac ticket: https://core.trac.wordpress.org/ticket/55395

#2 @kraftbj
2 years ago

  • Keywords has-patch removed
  • Owner set to kraftbj
  • Status changed from new to accepted

peterwilsoncc commented on PR #2416:


2 years ago
#3

Some of the handshake emoji include ZWJ (U+200D), for example https://emojipedia.org/handshake-light-skin-tone-medium-light-skin-tone/

#4 @peterwilsoncc
2 years ago

  • Type changed from enhancement to task (blessed)

Marking this a task rather than an enhancement, work can continue after the enhancement deadline.

#5 @milana_cap
2 years ago

  • Keywords needs-codex added

desrosj commented on PR #2416:


2 years ago
#6

I've made a few updates!

  • Synced with trunk.
  • I changed the URLs to be 14.0.0 instead of 14.0.1. Since these new emoji were introduced in 14.0.0, I think it makes more sense to use that version for this update.
  • I opted to use the Handshake: Light Skin Tone, Dark Skin Tone. I've updated the necessary locations.

I've tested this on my machine (which does not yet have Emoji 14 support) by replacing the Core CDN URLs with the GitHub ones for the Twemoji repo (https://github.com/twitter/twemoji/raw/v14.0.2/assets/), and all seems to be working as expected!

kraftbj commented on PR #2416:


2 years ago
#7

Thanks for the updated patch! I've confirmed it does replace on my older device that doesn't support Emoji 14 and does not replace on my upgraded device with 14 support.

We need to coordinate with a CDN committer to get the assets added, but once that's done, this is good to go.

This ticket was mentioned in Slack in #meta by peterwilsoncc. View the logs.


2 years ago

#9 @kraftbj
2 years ago

  • Keywords commit added

Assets added in r18735-dotorg. The CDN is ready: https://s.w.org/images/core/emoji/14.0.0/svg/1fae0.svg

#10 @kraftbj
2 years ago

Per feedback in the PR, there is some doubt if using the {right|left}hand in the detection script is proper due to a comment there mentioning that only older emoji should be used.

In the PR, @peterwilsoncc and I agree that we should land this for beta 1, then do intentional testing on older devices/operating systems so any updates can be made during the beta window.

#11 @peterwilsoncc
2 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 53150:

Emoji: Update the Twemoji to version 14.0.2.

This version introduces support for the latest Emoji added in Emoji 14.

"Insert witty comment newly supported emoji."

Props kraftbj, desrosj, dd32, milana_cap.
Fixes #55395.

peterwilsoncc commented on PR #2416:


2 years ago
#12

Merged in https://core.trac.wordpress.org/changeset/53150, thanks.

I resolved the weird package-lock issue by ignoring the file in this PR and letting NPM do the work.

#13 @dd32
2 years ago

  • Keywords needs-user-docs added; needs-codex removed

#14 @milana_cap
2 years ago

  • Keywords add-to-field-guide added

#15 @kraftbj
2 years ago

  • Keywords commit removed
Note: See TracTickets for help on using tickets.