Make WordPress Core

Opened 2 years ago

Closed 19 months ago

#55698 closed defect (bug) (worksforme)

Twenty Twenty: "x" not showing in the default font

Reported by: moniquebouchard's profile moniquebouchard Owned by:
Milestone: Priority: normal
Severity: major Version: 5.9.3
Component: Bundled Theme Keywords: needs-testing
Focuses: Cc:

Description

Hi,

I noticed that when using the default font set in twenty-twenty, the letter "x" was not showing, and instead the " (right quote) was showing instead! (I'm calling this "major" because the letter x is kind of important to anyone creating content.)

This was a fresh install of WordPress and twenty twenty, without (at that time) any extra plugins. Everything was the default at that point; no plugins or other tools were in use.

I'm unfortunately past being able to replicate it at this point. I've since added a plugin to change the fonts anyway, but it was a super odd issue. Was happening on a "page" and it didn't matter what the x was in - regular text and links were equally affected.

The workaround is fine (font change) but it may be a glitch associated with an update?

Change History (7)

#1 @sabernhardt
2 years ago

Hi and thanks for the report!

Could you share a full sentence (or phrase) that included the wrong character? The x is sometimes replaced. For example, in English, "4x4" becomes "4×4" (4×4). This should not change all x characters, though.

If you had no plugins, you probably created content with the block editor. Could you confirm that?

Also, do you know which browser and operating system were you using?

#2 @SergeyBiryukov
2 years ago

  • Keywords reporter-feedback added

#3 @SergeyBiryukov
2 years ago

  • Component changed from Formatting to Bundled Theme
  • Summary changed from Default font twenty twenty error to Twenty Twenty: "x" not showing in the default font

#4 @moniquebouchard
2 years ago

The browser is Chrome on a Mac running Monterey 12.3.1
I was using the standard editor (so not using any groups, or special layouts or anything, just straight up block posts.) It happened in both paragraph and H tags.

Had the x changed to × it would make more sense. But changing straight up to " was very odd.

The specific content that I noted this in is as follows:

One was the word "extensively" in which the x was replaced by " so it read e"tensively. (I did not try to see if X (capital) was different from x (lowercase) as it only occurred to me just now.)

“…Bangor historian Monique Bouchard has researched Jones extensively, and dons her persona when leading walking tours for the Bangor Historical Society. Would Jigger Johnson and Fan Jones have encountered one another, when Johnson was a strapping young lumberjack in the 1890s, and Jones was the elder stateswoman, as it were, of Bangor brothel-keepers?”

The other, which was where I first noticed it as it broke the link, was when I realized the text read fo"23maine.com rather than fox.

This web address https://fox23maine.com/amp/news/offbeat/the-story-of-the-wild-maine-lumberjack-who-inspired-the-name-of-a-local-gin

(If you try it, the link will fail regardless, but if you search "fox 23 maine jigger and jones" you'll see the link I had grabbed, not realising they'd archived the content or something.)

#5 @sabernhardt
2 years ago

  • Keywords needs-testing added; reporter-feedback removed

Thanks for more details. I was not able to reproduce the error with my content in macOS 10.13.6 (Chrome 91 & 101, Firefox 100, Safari 13.1.2), but maybe someone else can.

Twenty Twenty has different sets of fonts for headings and paragraph text, so I'm not convinced this is related to a font.

Last edited 2 years ago by sabernhardt (previous) (diff)

#6 @moniquebouchard
2 years ago

I do have to spin up another site in a couple of weeks. I'll see if I can get the issue to reproduce when that happens, and if it does, I'll reopen this thread. I'm glad it appears to be a special quirk that I (alone hopefully!) experienced!

#7 @sabernhardt
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I'll close the ticket. It might have been a problem with the news feed or something we cannot replicate anymore. If you experience this (or similar) again, please reopen.

Note: See TracTickets for help on using tickets.