Make WordPress Core

Opened 2 years ago

Closed 2 months ago

#56001 closed defect (bug) (wontfix)

Twenty Twenty Two: Pullquote Block: No Lowercase for Add Citation Text

Reported by: nithins53's profile nithins53 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.0
Component: Bundled Theme Keywords: close
Focuses: css Cc:

Description

In Twenty Twenty Two theme when we add the pullquote block, the citation text will be in uppercase even if the caps lock is off.

Steps to replicate:

  1. Activate Twenty Twenty Two theme
  2. Insert Pullquote Block
  3. Enter citation text

For more information, the screen recording link is attached below.

https://www.loom.com/share/1f8b07daca9f46188f9a257d381e821d

Change History (6)

#1 @sabernhardt
2 years ago

  • Focuses css added

Thanks for the report!

This is not defined (directly) by the theme. The uppercase style comes from 'wp-block-pullquote-inline-css', which uses the editor's theme.scss.

#2 @kajalgohel
2 years ago

Hello @nithins53,

Thanks for reporting this! In this citation text if you check there is one css text-transform:uppercase;
If it is not intentionally, we should removed that then the issue is resolved.

.wp-block-pullquote__citation, .wp-block-pullquote cite, .wp-block-pullquote footer {
    color: currentColor;
    text-transform: none;
    font-size: .8125em;
    font-style: normal;
}

Thanks

#3 @aezazshekh
2 years ago

Hello @nithins53

The uppercase style doesn't seem to come from the theme.

So you have to add the following style to the theme, due to which this issue will be solved.

.wp-block-pullquote__citation, .wp-block-pullquote cite, .wp-block-pullquote footer {
    text-transform: none;
}

#4 @nithins53
2 years ago

Why is this issue happening only with the Twenty Twenty Two theme and not others? @kajalgohel @aezazshekh
Thank You.

#5 @karmatosed
2 months ago

  • Keywords close added

This seems to not be something to resolve in the theme. Some themes may have styling that impacts and others like this don't. As a result, I am going to recommend adding the close keyword to this ticket and moving it on. Thank you everyone for the collaboration so far. We can always reconsider if needed.

#6 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thank you, I am going to follow through and close this.

Note: See TracTickets for help on using tickets.