Make WordPress Core

#56540 closed defect (bug) (duplicate)

Twenty Sixteen: Pullquote block text color is not reflected at editor and front side both

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.0.2
Component: Bundled Theme Keywords:
Focuses: ui, css Cc:

Description

Steps to reproduce:-

  1. Activate Twenty Sixteen theme.
  2. Choose Pullquote block.
  3. Add text color and see the post.

Both editor and front side color is not reflected.

Attachments (2)

56540.patch (1.4 KB) - added by nidhidhandhukiya 21 months ago.
56540.diff (2.1 KB) - added by mahfuz01 21 months ago.
This only applies to the blockquote when the user has chosen any color which means blockquote parent .has-text-color class in it. Otherwise, It always has the default color.

Download all attachments as: .zip

Change History (4)

#1 @poena
21 months ago

Hi!

This PR would be a breaking change for users who is not using the text color option, or that uses an older WordPress version where the text color option is not enabled.

On existing sites, the text color that is already in use would be removed, and that would be an unexpected change for users.
Also, please consider that the quote text and citation text has different colors in this theme, and that the design should be respected.

In WordPress 6.0.2, pull quote blocks that has a text color added with the color option receives a CSS class called has-text-color. Have you tried using that class to limit the CSS change to when the color option is in use?

@mahfuz01
21 months ago

This only applies to the blockquote when the user has chosen any color which means blockquote parent .has-text-color class in it. Otherwise, It always has the default color.

#2 @sabernhardt
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Twenty Sixteen Pullquote block text color is not reflected at editor and front side both to Twenty Sixteen: Pullquote block text color is not reflected at editor and front side both

Duplicate of #56008.

This is already done in r54381.

Note: See TracTickets for help on using tickets.