Make WordPress Core

#56589 closed defect (bug) (duplicate)

Add missing `_deprecated_function()` calls in deprecated functions

Reported by: desrosj's profile desrosj Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: good-first-bug has-patch needs-testing
Focuses: Cc:

Description (last modified by desrosj)

There are several older deprecated functions that do not have a _deprecate_function() call inside them.

  • Admin deprecated: 10
  • Admin MS deprecated: 1
  • Normal deprecated: 1

Without this function, site owners are never informed that a deprecated function is being called on their site, and of the intended replacement if one exists. A _deprecated_function() call should be added to these for consistency.

Change History (7)

This ticket was mentioned in PR #3375 on WordPress/wordpress-develop by CrochetFeve0251.


19 months ago
#1

  • Keywords has-patch added; needs-patch removed

Added missing _deprecated_function call in deprecated functions missing it.

Trac ticket: 56589

#2 @JeffPaul
19 months ago

  • Keywords needs-testing added

#3 @SergeyBiryukov
19 months ago

  • Summary changed from Add missing `__depreacted_function()` calls in deprecated functions to Add missing `_deprecated_function()` calls in deprecated functions

#4 @desrosj
19 months ago

  • Description modified (diff)
  • Milestone changed from Future Release to 6.2

#5 @jrf
17 months ago

This sounds like a duplicate of #41121, which created a huge discussion on "soft" deprecations versus "hard" deprecations, which is why that ticket is still open.

I think that discussion needs to be resolved first ?

#6 @shubham1gupta
15 months ago

The Ticket 41121 is not updated from 2 years, can we take the _deprecated_function() as the truth ?

#7 @desrosj
15 months ago

  • Milestone 6.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41121.

Going to close this out as a duplicate to keep all conversation in one place.

Note: See TracTickets for help on using tickets.