Make WordPress Core

#56643 closed defect (bug) (reported-upstream)

Twenty Twenty-Three: Post Meta block initially not visible when added to post

Reported by: ashleyleia's profile ashleyleia Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1
Component: Themes Keywords:
Focuses: Cc:

Description

When adding a Post Meta block to a post in the block editor using Twenty-Twenty-Three theme, the content of the block is initially not visible. The block toolbar is visible, but after clicking away from the block, the block disappears entirely.

Steps to reproduce:
1) Create a new post
2) Click the "+" add block button
3) Click browse all
4) Select Post Meta block -> block toolbar appears, but there's no content
5) Click elsewhere on the screen -> block disappears

Where the Post Meta block is expected, there's a <div> with data-title="Template Part" and a nested <div> with data-title="Pattern".

This occurs when adding a Post Meta block to a new post or to an existing draft or already-published post. The block is visible when previewing the post in a new tab, and it becomes visible in the editor after the screen is refreshed or after navigating away from and back to the post.

I'm using 6.1 Beta 1 with no active plugins, on MacOS in both Chrome and Safari.

Attachments (2)

Post Meta invisible block.png (641.1 KB) - added by ashleyleia 21 months ago.
Post Meta block toolbar.png (134.4 KB) - added by ashleyleia 21 months ago.

Download all attachments as: .zip

Change History (9)

#1 @desrosj
21 months ago

  • Milestone changed from Awaiting Review to 6.1
  • Summary changed from 6.1 Beta-1 Twenty-Twenty-Three: Post Meta block initially not visible when added to post to Twenty Twenty-Three: Post Meta block initially not visible when added to post

#2 @nithins53
21 months ago

@ashleyleia I can't reproduce the issue on 6.1 beta 2 version. can you check again?

Last edited 21 months ago by nithins53 (previous) (diff)

#3 @ashleyleia
21 months ago

@nithins53 The issue is still happening for me with 6.1 beta 2. It only happens when the post meta block is added specifically via "Browse all."

Last edited 21 months ago by ashleyleia (previous) (diff)

#4 @poena
21 months ago

The post meta is a template part, and template parts are not intended to be available in the block editor.
This will be solved once the solution for this issue is added to WordPress core https://github.com/WordPress/gutenberg/issues/44397

#5 @desrosj
21 months ago

  • Keywords close added

This was solved in GB-44480, and is slated to be merged into Core prior beta 3. I'm going to leave this open, but will add a suggestion to close this out as reported-upstream.

@ashleyleia if you are able, could you please test when beta 3 is released on Tuesday to confirm your issue is solved?

#6 @ashleyleia
21 months ago

@desrosj The issue I reported is resolved as the "post meta" block is no longer available. However, template part blocks can still be added in the post editor. I'll mention this and add a screenshot in / GB-44480.

#7 @desrosj
21 months ago

  • Keywords close removed
  • Milestone 6.1 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Thank you! Looking there it seems like this is solved as well.

Note: See TracTickets for help on using tickets.