Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 15 months ago

#57174 closed defect (bug) (fixed)

space showing as as URL encoded character after searching for plugin

Reported by: 254volkan's profile 254volkan Owned by: audrasjb's profile audrasjb
Milestone: 6.2 Priority: normal
Severity: normal Version: 6.1
Component: Plugins Keywords: has-patch has-screenshots
Focuses: javascript, administration Cc:

Description

Screenshot here https://ibb.co/GnVj1kW

Attachments (6)

Screenshot 2022-11-22 at 12.36.51.png (144.1 KB) - added by 254volkan 18 months ago.
57174.2.patch (500 bytes) - added by dilipbheda 18 months ago.
Here is the patch to fix this issue.
57174.diff (1.1 KB) - added by adhun 18 months ago.
This patch will show the decode search keyword on plugins install page.
Screenshot 2022-11-28 at 11.49.27 AM.png (221.4 KB) - added by syamraj24 18 months ago.
After applying the patch plugin search page looks fine.
Screenshot 2022-11-28 at 11.50.09 AM (1).png (1.4 MB) - added by syamraj24 18 months ago.
Also the pagination with special characters working fine as expected. #56339 issue is not getting reverted after applying the above patch.
Capture d’écran 2022-11-29 à 23.45.44.png (223.3 KB) - added by audrasjb 18 months ago.
After patch: looks great

Download all attachments as: .zip

Change History (19)

@dilipbheda
18 months ago

Here is the patch to fix this issue.

#1 @dilipbheda
18 months ago

  • Component changed from Query to Plugins
  • Focuses administration added
  • Keywords has-patch added; needs-patch removed

@254volkan Thank you for the ticket.

I Have reviewed this issue and fixed it with the attached patch.

It seems the issue created by the previous ticket: https://core.trac.wordpress.org/ticket/56339

Thanks

#2 @audrasjb
18 months ago

  • Owner set to audrasjb
  • Status changed from new to reviewing
  • Version changed from 6.1.1 to 6.1

Introduced in [53844].

#3 @audrasjb
18 months ago

  • Focuses javascript added; accessibility removed
  • Keywords changes-requested added
  • Severity changed from trivial to normal

Hello @254volkan, welcome to WordPress Core Trac, and thanks for the ticket!

@dilipbheda thanks for the patch too, but this would revert [53844] which fixed an issue with some characters (see the related ticket). We need an implementation that doesn't revert that fix :)

#4 @254volkan
18 months ago

Hi @audrasjb
Yes, this is on 6.1.1 which is the most recent release

#5 @audrasjb
18 months ago

To clarify @254volkan I moved the Version information from 6.1.1 to 6.1 because this metadata is about the version that introduced the issue, not the version you reproduced the issue ;-)

@adhun
18 months ago

This patch will show the decode search keyword on plugins install page.

#7 @adhun
18 months ago

The above patch will show the url decoded string on plugin install page.
Also this #56339 issue is not coming back after applying the above patch.

@syamraj24
18 months ago

After applying the patch plugin search page looks fine.

@syamraj24
18 months ago

Also the pagination with special characters working fine as expected. #56339 issue is not getting reverted after applying the above patch.

@audrasjb
18 months ago

After patch: looks great

#8 @audrasjb
18 months ago

  • Keywords has-screenshots added; changes-requested removed

This new patch looks good to me (see above screenshot). I'll add a PR just to make sure tests are passing well, then commit. Thanks.

#9 @audrasjb
18 months ago

  • Milestone changed from Awaiting Review to 6.2

#11 @audrasjb
18 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 54904:

Plugins: Correctly display spaces in installed plugins search results.

This changeset improves searched terms URL decoding in installed plugins search results.

Follow-up to [53844].

Props 254volkan, dilipbheda, audrasjb, adhun, syamraj24.
Fixes #57174.

This ticket was mentioned in Slack in #core by costdev. View the logs.


15 months ago

Note: See TracTickets for help on using tickets.