Make WordPress Core

Opened 15 months ago

Last modified 15 months ago

#57519 new defect (bug)

Sundry Menu Bugs

Reported by: dbareis's profile dbareis Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 6.1.1
Component: Menus Keywords:
Focuses: ui Cc:

Description

My "TEST MENU (don't use)" has a submenu. Bugs:

  1. For ages the color of that menu text was black, it is now white (nothing was changed by me).
  1. It is a custom link with the "disable link" option set, yet clicking it still goes to the URL (which I had to enter as it wouldn't save otherwise. OK I see the issue now, even though it is below the URL you have to click it first. The checkbox is a UI only option and no check is performed for the URL being empty.
  1. The menu is impossible to open as it displayed off the right of the screen, I can only display it by reducing the width of the window such that the next level up menu displayed on a new line (plenty of room to open a submenu). All menus I have seen handle this problem by opening to the left in this scenario.
  1. If used on the footer it doesn't even display submenus correctly. It displays them at the same level.

[No image attached after all as I haven't got a clue how to do so]

ANOTHER BUG:
GOT "You've not yet selected a component. Please check the "Component" option above or select from one of the following" even though "Menus" was selected

Change History (1)

#1 @dbareis
15 months ago

Menu Bug 5: It also gets chopped off at the bottom for long vertical menus.

Last edited 15 months ago by dbareis (previous) (diff)
Note: See TracTickets for help on using tickets.